Bug 723357 - fedora-storage-init needs to call multipath with -n option.
fedora-storage-init needs to call multipath with -n option.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-19 18:42 EDT by Ben Marzinski
Modified: 2014-03-16 23:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-22 13:43:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add the -n option to multipath call (609 bytes, patch)
2011-07-19 18:42 EDT, Ben Marzinski
no flags Details | Diff

  None (edit)
Description Ben Marzinski 2011-07-19 18:42:54 EDT
Created attachment 513891 [details]
Patch to add the -n option to multipath call

starting with device-mapper-multipath-0.4.9-17.fc16, multipath has a -n option that disables syncing with udev. It needs to be called with this option by fedora-storage-init during startup
Comment 1 Bill Nottingham 2011-07-20 13:50:35 EDT
Why do we need to disable syncing with udev - I would think we would want to.
Comment 2 Ben Marzinski 2011-07-21 01:09:55 EDT
So multipath is usable for the alpha release. I'm not sure why udev synchronization is failing during startup, but it is. And you can't boot the machine at all with multipathing enabled if its udev synchronization code is also enabled.  It's quite possible that when I figure out the root of this issue, it can safely be re-enabled. But I haven't found the root cause of this issue yet, and the alpha release is coming quickly, and I'd really like people to be able to use multipathing and be able to reboot their machines for alpha.
Comment 3 Bill Nottingham 2011-07-22 13:43:13 EDT
Pushed in 9.31-2 as a patch; will wait to put upstream.

Note You need to log in before you can comment on or make changes to this bug.