Bug 723399 - Fatal error when building default book using JBoss brand
Fatal error when building default book using JBoss brand
Status: CLOSED WONTFIX
Product: Publican
Classification: Community
Component: publican-jboss (Show other bugs)
2.5
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ruediger Landmann
Jeff Fearn
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-19 23:02 EDT by Dana Mison
Modified: 2013-07-29 19:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-29 19:27:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dana Mison 2011-07-19 23:02:41 EDT
Description of problem:
Creating a new book using the JBoss brand will result in a book that will not build because the common content Feedback section now uses several new entities that are not defined with placeholders in the generated bookname.ent file

It actually produces a FATAL ERROR. 

Version-Release number of selected component (if applicable):
publican 2.5-1.fc14
publican-jboss 2.6-1.fc14

How reproducible:
Everytime.

Steps to Reproduce:
1. publican create book --name jtest --brand JBoss
2. publican build --formats=html --lang=en-US
  
Actual results:
FATAL ERROR: parser:27 in Common_Content/Feedback.xml on line 61: Entity 'BZURL' not defined
at /usr/bin/publican line 672

Book will not build until you add entries for BZURL, BZCOMPONENT and BZPRODUCT in bookname.ent

Expected results:
Book builds with placeholder content for those entities, like it does with the HOLDER entity

Additional info:
Note: have been told that this is "expected behaviour" for this brand because there is no way to specify entities at the brand level.  

Suggest the place holders could be added into the default .ent file, with a comment in the entities file saying that these are a workaround the brand and they can be removed if that brand is not used.  

Fatal errors should not be the output of using supplied defaults.
Comment 2 Ruediger Landmann 2013-07-29 19:27:14 EDT
The brand has no access to the entities file of a book, so I can't see any way to pre-populate these entities for a new book.

Having new books fail to build until these entities are populated is the cost of including entities like this in the brand.

Note You need to log in before you can comment on or make changes to this bug.