Bug 723435 - kdump doesn't work because of "IO-APIC + timer doesn't work"
kdump doesn't work because of "IO-APIC + timer doesn't work"
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.7
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Gleb Natapov
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier1
  Show dependency treegraph
 
Reported: 2011-07-20 03:04 EDT by Suqin Huang
Modified: 2013-12-08 19:55 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-16 20:44:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel panic (20.22 KB, image/png)
2011-07-20 03:04 EDT, Suqin Huang
no flags Details
serial info (7.16 KB, text/plain)
2011-07-21 22:10 EDT, Suqin Huang
no flags Details

  None (edit)
Description Suqin Huang 2011-07-20 03:04:16 EDT
Created attachment 513937 [details]
kernel panic

Description of problem:
enable kdump in guest, trigger kernel panic, kdump doesn't work because of IO-APIC + timer doesn't work

Version-Release number of selected component (if applicable):
kvm-83-239.el5

How reproducible:
100%

Steps to Reproduce:
1. cmd
/usr/libexec/qemu-kvm -monitor stdio -drive file='/images/RHEL-Server-5.7-64-virtio.qcow2',index=0,if=virtio,media=disk,cache=none,boot=on,format=qcow2 -net nic,vlan=0,model=virtio,macaddr='9a:ba:99:1b:87:3a' -net tap,vlan=0,ifname='t0-171628-6Bso',script='/home/scripts/qemu-ifup-switch',downscript='no' -m 2048 -smp 4,cores=1,threads=1,sockets=4 -cpu qemu64,+sse2 -soundhw ac97 -vnc :0 -rtc-td-hack -M rhel5.6.0 -boot c  -usbdevice tablet

2. enable kdump 
3. echo c > /proc/sysrq-trigger
  
Actual results:
kdump doesn't work because of "IO-APIC + timer doesn't work" 

Expected results:


Additional info:
1. the same guest work on rhel6 host
2. guest
rhel5.7.64 (2.6.18-274.el5)

3. host
2.6.18-274.el5

processor	: 1
vendor_id	: AuthenticAMD
cpu family	: 15
model		: 107
model name	: AMD Athlon(tm) Dual Core Processor 5400B
stepping	: 2
cpu MHz		: 1000.000
cache size	: 512 KB

flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy misalignsse
bogomips	: 2004.17
TLB size	: 1024 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc 100mhzsteps
Comment 1 Suqin Huang 2011-07-20 04:19:53 EDT
it works when boot guest with "-smp 1,cores=1,threads=1,sockets=1"
Comment 2 Suqin Huang 2011-07-20 04:24:40 EDT
also work if add noapic to kernel line when boot guest with multi cpu
Comment 5 Suqin Huang 2011-07-21 07:13:49 EDT
guest stop when add noapic to KDUMP_COMMANDLINE_APPEND in /etc/sysconfig/kdump.

1. serial info:

PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a report
NetLabel: Initializing
NetLabel:  domain hash size = 128
NetLabel:  protocols = UNLABELED CIPSOv4
NetLabel:  unlabeled traffic allowed by default
ACPI: DMAR not present
PCI-GART: No AMD northbridge found.
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 1, 8192 bytes)
TCP established hash table entries: 4096 (order: 4, 65536 bytes)
TCP bind hash table entries: 2048 (order: 3, 32768 bytes)
TCP: Hash tables configured (established 4096 bind 2048)
TCP reno registered
audit: initializing netlink socket (disabled)
type=2000 audit(1311246263.000:1): initialized
Total HugeTLB memory allocated, 0
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
Initializing Cryptographic API
alg: No test for crc32c (crc32c-generic)
ksign: Installing public key data
Loading keyring
- Added public key 5E046EE793D43754
- User ID: Red Hat, Inc. (Kernel Module GPG key)
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)
Limiting direct PCI/PCI transfers.
Activating ISA DMA hang workarounds.
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
Real Time Clock Driver v1.12ac
Non-volatile memory driver v1.2
Linux agpgart interface v0.101 (c) Dave Jones
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled

2. #cat /proc/cmdline 
ro root=/dev/VolGroup00/LogVol00 console=ttyS0,115200 console=tty0 crashkernel=128M@16M

3. 
KDUMP_COMMANDLINE_APPEND="irqpoll maxcpus=1 reset_devices noapic"
Comment 6 Gleb Natapov 2011-07-21 07:25:50 EDT
(In reply to comment #5)
> guest stop when add noapic to KDUMP_COMMANDLINE_APPEND in /etc/sysconfig/kdump.
> 
> 1. serial info:
> 
> Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
> 
That looks like bug 611407 which means you are using old guest kernel and noapic was not properly appended to kdump kernel cmd. Can you update your guest kernel and append full serial output to verify that noapic was part of kernel cmd.
Comment 7 Suqin Huang 2011-07-21 21:57:28 EDT
I'm using the latest kernel 2.6.18-274.el5
Comment 8 Suqin Huang 2011-07-21 22:10:59 EDT
Created attachment 514603 [details]
serial info

Note You need to log in before you can comment on or make changes to this bug.