Bug 723480 - spice-protocol: update to upstream 0.8.1
spice-protocol: update to upstream 0.8.1
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-protocol (Show other bugs)
6.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Hans de Goede
Desktop QE
: Rebase
Depends On:
Blocks: 688883
  Show dependency treegraph
 
Reported: 2011-07-20 06:35 EDT by Uri Lublin
Modified: 2011-12-06 10:11 EST (History)
4 users (show)

See Also:
Fixed In Version: spice-protocol-0.8.1-1.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
The package spice-protocol has been updated to be based on upstream spice-protocol-0.8.1 The following was added: * Add support for volume change * Add support for async guest io writes and interrupt * Add support for suspend (S3) related guest io writes * Add support for interrupt indicating guest bug
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 10:11:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Uri Lublin 2011-07-20 06:35:10 EDT
Description of problem:

Update spice-protocol to upstream 0.8.1.
Patches include:
* Add support for volume change
* Add support for async guest io writes and interrupt
* Add support for suspend related guest io writes (aka S3)
* Add support for interrupt indicating guest bug
Comment 2 RHEL Product and Program Management 2011-07-20 06:58:15 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 3 Alon Levy 2011-07-20 08:10:38 EDT
Dear PM,

 To fix the already pm-acked #688883 (suspend support) spice-protocol needs to be updated. It's my understanding there are two ways to do it: rebase, or add patches. I would rather rebase - there is no difference in the resulting code, and it keeps the upstream version and rpm version in sync.

Alon
Comment 7 Uri Lublin 2011-07-23 18:39:54 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The package spice-protocol has been updated to be based on upstream spice-protocol-0.1.1

The following was added:
* Add support for volume change
* Add support for async guest io writes and interrupt
* Add support for suspend (S3) related guest io writes
* Add support for interrupt indicating guest bug
Comment 9 Alon Levy 2011-07-23 19:31:13 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,4 +1,4 @@
-The package spice-protocol has been updated to be based on upstream spice-protocol-0.1.1
+The package spice-protocol has been updated to be based on upstream spice-protocol-0.8.1
 
 The following was added:
 * Add support for volume change
Comment 12 errata-xmlrpc 2011-12-06 10:11:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1629.html

Note You need to log in before you can comment on or make changes to this bug.