Bug 723499 - ext4 fs error after resume from hibernate
ext4 fs error after resume from hibernate
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
unspecified Severity high
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
ext4 hibernate first=
Depends On:
Blocks: kernel_hibernate
  Show dependency treegraph
Reported: 2011-07-20 07:34 EDT by Stefan Assmann
Modified: 2013-07-31 20:10 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-07-31 20:10:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
dmesg.txt (899.47 KB, text/plain)
2011-07-20 07:34 EDT, Stefan Assmann
no flags Details

  None (edit)
Description Stefan Assmann 2011-07-20 07:34:53 EDT
Created attachment 513984 [details]

Description of problem:
System came out of hibernation and the desktop was unresponsive but the hdd was very busy. Checking dmesg revealed a lot of

Jul 20 11:50:21 samsung kernel: [ 9692.030048] EXT4-fs error (device sda2): mb_free_blocks:1397: group 99block 3253569:freeing already freed block (bit 9537)
Jul 20 11:50:21 samsung kernel: [ 9692.031987] EXT4-fs error (device sda2): mb_free_blocks:1397: group 99block 3253570:freeing already freed block (bit 9538)
Jul 20 11:50:21 samsung kernel: [ 9692.033829] EXT4-fs error (device sda2): mb_free_blocks:1397: group 99block 3253571:freeing already freed block (bit 9539)

Filesystem had to be manually fscked after reboot with errors fixed.

Version-Release number of selected component (if applicable):

How reproducible:
once so far
Comment 1 Eric Sandeen 2011-12-07 13:58:11 EST
First messages from ext4 were:

Jul 20 11:46:03 samsung kernel: [ 9433.532983] EXT4-fs error (device sda2): ext4_mb_generate_buddy:731: group 427569 blocks in bitmap, 7568 in gd
Jul 20 11:46:03 samsung kernel: [ 9433.533209] JBD: Spotted dirty metadata buffer (dev = sda2, blocknr = 0). There's a risk of filesystem corruption in case of system crash.

with a lot of others following.

blocknr = 0 is the superblock ...

This plus other bugs lately make me think that ext4 sync is not working properly.
Comment 2 Josh Boyer 2012-03-28 14:00:25 EDT
[Mass hibernate bug update]

Dave Airlied has found an issue causing some corruption in the i915 fbdev after a resume from hibernate.  I have included his patch in this scratch build:


This will probably not solve all of the issues being tracked at the moment, but it is worth testing when the build completes.  If this seems to clear up the issues you see with hibernate, please report your results in the bug.
Comment 3 Bojan Smojver 2012-04-24 17:34:36 EDT
Similar errors still present in F-16. I guess this is the same (or similar) as bug #744275.

PS. I have a system that was exhibiting i915 corruption, which is now fixed. This appears to be an unrelated ext4 problem.
Comment 4 Jonas Thiem 2012-05-13 20:45:16 EDT
Just got the same ext4_mb_generate_buddy error after hibernate/resume. Strange symptoms followed: /var/cache/ gave I/O error when attempting to write inside, although parent folders worked fine on the same partition. A reboot fixed it. I use F17 and kernel 3.3.4-4. Would be nice if this issue could be figured out since I don't really dare using hibernate until this is fixed..
Comment 5 Dave Jones 2012-06-05 17:54:35 EDT
https://lkml.org/lkml/2012/6/4/470 seems to be a related upstream discussion over the ext4_mb_generate_buddy message.

bug 822071 is an f17 variant of the same. (There's at least one other similar).
Given f15 is due for eol at the end of this month, I suspect we'll migrate this bug to 17, and dupe the others against this.
Comment 6 Fedora End Of Life 2013-07-03 18:20:59 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 7 Fedora End Of Life 2013-07-31 20:10:41 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.