Bug 72361 - splash screen hides error dialog on startup with wrong repository path
splash screen hides error dialog on startup with wrong repository path
Status: CLOSED WONTFIX
Product: eCos
Classification: Retired
Component: ConfigTool (Show other bugs)
1.5.5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bart Veer
eCos bugs internal list
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-23 02:37 EDT by Martin Hansen
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-20 12:17:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Hansen 2002-08-23 02:37:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
If I start eCos config tool. And the path to the repository is somehow bad, 
either becuse i have given a wrong path last time i startet the config tool, or 
the repository has moved. I got stuck.
The problem seems to be that the dialog that tells me that the path is not 
pointing to a repository, is hidden behind the splash screen, and the splash 
sreen don't time out as long as I don't click "OK", but i can't click "OK" 
becuase the dialog is hidden (deadlock).
It took some time a bit of eksperimenting until a found out the the dialog was 
in there, it is impossible to see it, but i hear this "dong" sound, and if I 
press return, configtool continue its startup and the splash screen disapears.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start config tool
2. choose build -> repository
3. enter a valid path, but not one pointing to a repository e.g. c:\windows. 
And click "OK"
4. You get an error box, click "OK"
5. the dialog with the path reappears, now click "Cancel"
6. close config tool
7. start config tool	

Actual Results:  now you see the spalsh sreen, and it stays there, and you 
can't _see_ a way out.


Expected Results:  The spalsh screen should disapear revealing the dialog 
saying that the path to the repository was bad.

Additional info:

$ uname -a
CYGWIN_NT-5.0 W77163 1.3.12(0.54/3/2) 2002-07-06 02:16 i686 unknown

H:\>ver
Microsoft Windows 2000 [Version 5.00.2195]

I dont know if the ecos system as a hole has a version number, i can't fid it. 
But the version number af the config tool is 2.11 (the problem is also in 2.08)
There where no version numbers in this form that matched this.
Comment 1 Alex Schuilenburg 2003-06-20 12:17:07 EDT
This bug has moved to http://bugs.ecos.sourceware.org/show_bug.cgi?id=72361

Note You need to log in before you can comment on or make changes to this bug.