Bug 72372 - php-4.1.2-7.3.3 Package has too much Requirements for installation
php-4.1.2-7.3.3 Package has too much Requirements for installation
Status: CLOSED DUPLICATE of bug 72007
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-23 04:20 EDT by Klaus Steinberger
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-23 06:57:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
This patch removes the too strong requirements from the spec file (1.35 KB, patch)
2002-08-23 04:24 EDT, Klaus Steinberger
no flags Details | Diff

  None (edit)
Description Klaus Steinberger 2002-08-23 04:20:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020711

Description of problem:
The latest bug fix version of the php RPMS (4.1.2-7.3.3) has too strong
requirements for installation. The main Package requires also any Packages which
are required for the subpackages.

php requires the following packages which should be only required
by the appropriate subpackages:

imap
imap-devel
mysql
mysql-devel
postgresql
postgresql-devel
ucd-snmp
ucd-snmp-util
ucd-snmp-devel
unixODBC
unixODBC-devel

So it is not possible to install php if e.g. postgresql is not installed. These
requirements should be only in the subpackages.
e.g. php-pgsql should require postgresql.

The -devel Package should be even only BuildPreReqs ! Never Requirements for
installation!


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.try to install php-4.1.2-7.3.3 without postgresql
2.
3.
	

Additional info:
Comment 1 Klaus Steinberger 2002-08-23 04:24:38 EDT
Created attachment 72504 [details]
This patch removes the too strong requirements from the spec file
Comment 2 Ingo T. Storm 2002-08-23 06:05:41 EDT
Just a minor addition: I tried to use the patch and realized that (f)lex is 
missing in the BuildRequirements.

IngoTee
Comment 3 Ingo T. Storm 2002-08-23 06:57:21 EDT
libtool and gcc-c++ are missing from BuildRequires, too.

To be really strict: so are gcc, cpp.

regards,
IngoTee
Comment 4 Phil Copeland 2002-08-23 09:40:53 EDT
You'll find a much longer and involved discussion in #72007

*** This bug has been marked as a duplicate of 72007 ***

Note You need to log in before you can comment on or make changes to this bug.