This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 723723 - kadmin fails to start when using a custom DAL driver
kadmin fails to start when using a custom DAL driver
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: krb5 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nalin Dahyabhai
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 724033
  Show dependency treegraph
 
Reported: 2011-07-20 17:57 EDT by Simo Sorce
Modified: 2011-10-12 17:38 EDT (History)
1 user (show)

See Also:
Fixed In Version: krb5-1.9.1-8.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 724033 (view as bug list)
Environment:
Last Closed: 2011-07-27 14:41:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Simo Sorce 2011-07-20 17:57:42 EDT
The init script explicitly checks for a database file or pretend the db_library to be kldap.

I have a custom driver and the check fails.

At most the kadmin init script may check if db_library is present w/o trying to guess what value it should be set to.

But most probably it would be better to skip the check altogether and let kadmin log in /var/log/kadmin.log that there are errors.

The situation is particularly hard to discover because the initscript output is completely suppressed in F15 when systemctl gets involved.

I had to run it with SYSTEMCTL_SKIP_REDIRECT=1 to finally get the error and find out what was going on.
Comment 1 Fedora Update System 2011-09-16 16:41:04 EDT
krb5-1.9.1-12.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/krb5-1.9.1-12.fc15
Comment 2 Fedora Update System 2011-10-12 17:38:27 EDT
krb5-1.9.1-16.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/krb5-1.9.1-16.fc16

Note You need to log in before you can comment on or make changes to this bug.