Bug 723831 - - anaconda-16.12 - Got stuck due to "vmmouse_detect"
- anaconda-16.12 - Got stuck due to "vmmouse_detect"
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-21 05:50 EDT by Tao Wu
Modified: 2014-10-28 19:45 EDT (History)
8 users (show)

See Also:
Fixed In Version: lorax-16.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-12 06:23:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot when anaconda got stuck (28.64 KB, image/png)
2011-07-21 05:50 EDT, Tao Wu
no flags Details

  None (edit)
Description Tao Wu 2011-07-21 05:50:14 EDT
Created attachment 514173 [details]
screen shot when anaconda got stuck

Description of problem:
When start installation of Fedora-16-test-i386.iso on 'Virtual Machine Manager 0.8.7', switch the current activity window to some others, such as as a gnome-terminal, firefox and so on, then the anaconda will sometimes get stuck and claims that "failed to execute '/usr/bin/vmmouse_detect' like the attachment shows.

Version-Release number of selected component (if applicable):
16.12

How reproducible:
sometimes ( 60% )

Steps to Reproduce:
1. start installation of Fedora-16-test-i386.iso on 'Virtual Machine Manager 0.8.7'
2. switch the current activity window from the virtual machine to some others for a while
3. switch the activity window back to virtual machine and watch the status of anaconda
  
Actual results:
anaconda stop on the screen

Expected results:
anaconda works fine

Additional info:
I am not sure is this a problem of kvm, so I use an F15 iso to test on the same kvm, but it seems always work fine.
Comment 1 James Laska 2011-07-21 09:39:45 EDT
I'm definitely not seeing /usr/bin/vmmouse_detect included in the installer initrd.img.

# xz -d -c initrd.img  | cpio -it  | grep mouse
19875 blocks
xz: initrd.img: Compressed data is corrupt

Note, I'm seeing the "data is corrupt" message for the i386 and x86_64 initrd.img for both the 20110714 and 20110721 composes.  Could that be to blame?
Comment 2 James Laska 2011-07-21 09:42:14 EDT
(In reply to comment #1)
> Note, I'm seeing the "data is corrupt" message for the i386 and x86_64
> initrd.img for both the 20110714 and 20110721 composes.  Could that be to
> blame?

The same command on F-15 xz-compressed images works without error.  While there is no vmmouse_detect binary included in the F-15 ramdisk, it does however find other "vmmouse" files that are not present in F-16.

# xz -d -c /mnt/redhat/released/F-15/GOLD/Fedora/x86_64/os/images/pxeboot/initrd.img  | cpio -it  | grep vmmouse
usr/share/X11/xorg.conf.d/50-vmmouse.conf
usr/lib64/xorg/modules/input/vmmouse_drv.so
lib/udev/rules.d/69-xorg-vmmouse.rules
730528 blocks
Comment 3 Chris Lumens 2011-07-21 09:58:00 EDT
What happens if you hit ^C right here?
Comment 4 Tao Wu 2011-07-25 03:50:31 EDT
(In reply to comment #3)
> What happens if you hit ^C right here?

I have test again, and hit ^C on that moment, but it still stuck there, nothing happened. Fedora-16-test-20110721-3-i386.iso still have this problem.
Comment 5 Tao Wu 2011-07-25 04:09:03 EDT
(In reply to comment #2)
> (In reply to comment #1)
> > Note, I'm seeing the "data is corrupt" message for the i386 and x86_64
> > initrd.img for both the 20110714 and 20110721 composes.  Could that be to
> > blame?
> 
> The same command on F-15 xz-compressed images works without error.  While there
> is no vmmouse_detect binary included in the F-15 ramdisk, it does however find
> other "vmmouse" files that are not present in F-16.
> 
> # xz -d -c
> /mnt/redhat/released/F-15/GOLD/Fedora/x86_64/os/images/pxeboot/initrd.img  |
> cpio -it  | grep vmmouse
> usr/share/X11/xorg.conf.d/50-vmmouse.conf
> usr/lib64/xorg/modules/input/vmmouse_drv.so
> lib/udev/rules.d/69-xorg-vmmouse.rules
> 730528 blocks

So does that mean the F-16 miss some 'vmmouse' related files?  Because it will go against this Alpha Release Requirements:
 
   Where platform support exists, all dedicated installer images (except efidisk.img, which offers no options) must boot to the graphical boot menu and allow the user to select install options. If no option is selected, the installer should load after a reasonable timeout.

should this bug been marked as an F16 alpha block bug?
Comment 6 James Laska 2011-07-25 14:53:30 EDT
(In reply to comment #5)
> So does that mean the F-16 miss some 'vmmouse' related files?  Because it will
> go against this Alpha Release Requirements:

My comment was only to demonstrate that the vmmouse* program indeed is not provided in the initrd.img.  Whether that's good or bad, I don't know yet.

> should this bug been marked as an F16 alpha block bug?

If it happens to everyone, all the time ... yes.  If it happens to a single person, or only some of the time under specific conditions, likely not.

Let's try to figure out why my F15 system doesn't exhibit the problem.  Does anyone else on test@lists.fedoraproject.org see this problem?  Can you double check that your ISO's are images checksum properly?

Is this a new KVM guest that you are just created, or is this an existing guest you are repurposing?  Is there any thing special with how the guest is defined?
Comment 7 James Laska 2011-07-25 14:58:58 EDT
Update ... I just saw the same boot error you mention in comment#0 ("failed to execute '/usr/bin/vmmouse_detect') ... however my system continues with loader and prompts me for language and keymap settings.

How much memory does your guest have configured?
Comment 8 James Laska 2011-07-25 16:08:49 EDT
(In reply to comment #6)
> (In reply to comment #5)
> > So does that mean the F-16 miss some 'vmmouse' related files?  Because it will
> > go against this Alpha Release Requirements:
> 
> My comment was only to demonstrate that the vmmouse* program indeed is not
> provided in the initrd.img.  Whether that's good or bad, I don't know yet.

Turns out that the initrd.img is created differently in Fedora 16 and the message "Compressed data is corrupt" is because we don't yet have any user-space tools that understand how to unpack the initrd.img.  We'll need something to inspect the images in userspace ... but that can be tracked on anaconda-devel-list@
Comment 9 Tao Wu 2011-07-26 06:28:10 EDT
(In reply to comment #6)
> (In reply to comment #5)
> > So does that mean the F-16 miss some 'vmmouse' related files?  Because it will
> > go against this Alpha Release Requirements:
> 
> My comment was only to demonstrate that the vmmouse* program indeed is not
> provided in the initrd.img.  Whether that's good or bad, I don't know yet.
> 
> > should this bug been marked as an F16 alpha block bug?
> 
> If it happens to everyone, all the time ... yes.  If it happens to a single
> person, or only some of the time under specific conditions, likely not.
> 

Yes, this issue even doesn't always happen to me, it only has the possibility to happen when I switch my current active window to some other ones ( make the cursor on some other programs ).

> Let's try to figure out why my F15 system doesn't exhibit the problem.  Does
> anyone else on test@lists.fedoraproject.org see this problem?  Can you double
> check that your ISO's are images checksum properly?
> 

It seems that this did not happens to someone else ... I have checked the images' checksum, and the results are fine as the following:

[twu@localhost f16-pre-alpha]$ sha256sum -c Fedora-16-test-20110721-3-i386-CHECKSUM 
Fedora-16-test-20110721-3-i386.iso: OK
Fedora-16-test-20110721-3-i386-netinst.iso: OK

> Is this a new KVM guest that you are just created, or is this an existing guest
> you are repurposing?  Is there any thing special with how the guest is defined?

I have tested on both new KVM and an existing one, and it has chance to reproduced on both situation ...
Comment 10 Tao Wu 2011-07-26 06:33:17 EDT
(In reply to comment #7)
> Update ... I just saw the same boot error you mention in comment#0 ("failed to
> execute '/usr/bin/vmmouse_detect') ... however my system continues with loader
> and prompts me for language and keymap settings.
> 

Yeah, I almost see this error every time, but there are only some times it will get stuck, and the prerequisites of making it not get stuck is that the cursor can't be moved.

> How much memory does your guest have configured?

I configured 1512 MB for memory.
Comment 11 James Laska 2011-07-26 07:41:15 EDT
Thanks Martin, looks like a fix is out for review already ... 

https://www.redhat.com/archives/anaconda-devel-list/2011-July/msg00144.html

Note You need to log in before you can comment on or make changes to this bug.