Bug 723892 - [PATCH] systemd uses uid as default gid when User= specified
Summary: [PATCH] systemd uses uid as default gid when User= specified
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 733149 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-21 13:33 UTC by Paul Howarth
Modified: 2011-08-31 01:26 UTC (History)
8 users (show)

Fixed In Version: systemd-26-9.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-31 01:26:47 UTC


Attachments (Terms of Use)
Don't confuse uid and gid (478 bytes, patch)
2011-07-21 13:33 UTC, Paul Howarth
no flags Details | Diff

Description Paul Howarth 2011-07-21 13:33:50 UTC
Created attachment 514203 [details]
Don't confuse uid and gid

Description of problem:
When starting a service with User= specified but no Group= specified, systemd uses the uid of the specified user as the gid to use when starting the service. When the user's default gid is not the same as the user's uid, this is the wrong thing to do.

Version-Release number of selected component (if applicable):
systemd-26-8.fc15

Additional info:
I discovered this issue whilst writing a unit file for spamass-milter, and the attached patch fixes the problem for me. I checked upstream git and the affected code hasn't been changed.

Comment 1 Lennart Poettering 2011-08-01 19:34:24 UTC
Ouch! fixed in git. Thanks!

Will prep an update for F15.

Comment 2 Fedora Update System 2011-08-23 15:46:38 UTC
systemd-26-9.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/systemd-26-9.fc15

Comment 3 Lennart Poettering 2011-08-25 00:03:14 UTC
*** Bug 733149 has been marked as a duplicate of this bug. ***

Comment 4 Garrett Holmstrom 2011-08-25 01:43:57 UTC
Yep, systemd-26-9.fc15 fixes this.  Thanks!

Comment 5 Fedora Update System 2011-08-26 19:03:19 UTC
Package systemd-26-9.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-26-9.fc15'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/systemd-26-9.fc15
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2011-08-31 01:26:36 UTC
systemd-26-9.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.