Bug 723895 - AET middleware not supported
Summary: AET middleware not supported
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libcacard
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Alon Levy
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 682015
TreeView+ depends on / blocked
 
Reported: 2011-07-21 13:37 UTC by Alon Levy
Modified: 2011-12-06 16:22 UTC (History)
6 users (show)

Fixed In Version: libcacard-0.15.0-1.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Cause AET middleware reports support for CKM_RSA_X_590 while failing when requested to use it. Consequence libcacard based virtual card using a real AET middleware on the host fails to do any vcard_emul_rsa_op, failing for example pk11_listcerts. Fix libcacard now handles failure in CKM_RSA_X_590 by falling back to CKM_RSA_PKCS. Result Using AET backed virtual cards works, including pk11_listcerts or any other operation.
Clone Of:
Environment:
Last Closed: 2011-12-06 15:22:42 UTC
Target Upstream Version:


Attachments (Terms of Use)
fix for this bug. (6.81 KB, patch)
2011-07-21 13:37 UTC, Alon Levy
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1518 normal SHIPPED_LIVE libcacard and spice-client bug fix and enhancement update 2011-12-06 00:50:43 UTC

Description Alon Levy 2011-07-21 13:37:46 UTC
Created attachment 514204 [details]
fix for this bug.

Description of problem:
Using a spice smartcard connection with AET middleware doesn't work correctly due to the middleware reporting it supports CKM_RSA_X_509 when it doesn't.

fix is attached. sent to qemu upstream. (qemu mailing list is used for libcacard related fixes since libcacard is part of qemu code repository.)

Version-Release number of selected component (if applicable):
libcacard-0.1.2-2.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. start qemu with emulated smartcard (['-chardev', 'spicevmc,id=smartcard,debug=3,name=smartcard', '-device', 'usb-ccid,debug=1,id=ccid', '-device', 'ccid-card-passthru,debug=1,chardev=smartcard'])
2. start spicec with --enable-smartcard
3. smartcard appears in vm, but cannot complete a pk11_listcerts

Actual results:
errors

Expected results:
requests pin and shows certs.

Additional info:

Comment 1 Alon Levy 2011-07-21 13:40:15 UTC
Adding Rebase keyword. Since the previous version of libcacard (0.1.2-2) the sources have moved from an independent repository to be part of the qemu repository. This was not just a copy operation, but included fixes for reusing qemu infrastructure and applying qemu coding style, and a number of bug fixes have also been done on that code base. As a result a rebase of libcacard is recommended. It will include a fix for this bug.

Comment 3 RHEL Program Management 2011-07-21 13:57:52 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 12 Alon Levy 2011-11-21 10:27:50 UTC
Adding technical notes.

Comment 13 Alon Levy 2011-11-21 10:27:50 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
    AET middleware reports support for CKM_RSA_X_590 while failing when requested to use it.
Consequence
    libcacard based virtual card using a real AET middleware on the host fails to do any vcard_emul_rsa_op, failing for example pk11_listcerts.
Fix
    libcacard now handles failure in CKM_RSA_X_590 by falling back to CKM_RSA_PKCS.
Result
    Using AET backed virtual cards works, including pk11_listcerts or any other operation.

Comment 14 errata-xmlrpc 2011-12-06 15:22:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1518.html


Note You need to log in before you can comment on or make changes to this bug.