This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 723925 - [RFE] A method to disable rgmanager in cluster.conf
[RFE] A method to disable rgmanager in cluster.conf
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rgmanager (Show other bugs)
6.2
Unspecified Unspecified
high Severity low
: rc
: ---
Assigned To: Lon Hohberger
Cluster QE
: FutureFeature, TechPreview
Depends On:
Blocks: 917780
  Show dependency treegraph
 
Reported: 2011-07-21 11:00 EDT by Lon Hohberger
Modified: 2013-03-04 13:28 EST (History)
3 users (show)

See Also:
Fixed In Version: rgmanager-3.0.12.1-3.el6
Doc Type: Technology Preview
Doc Text:
As a consequence of converting the /etc/cluster.conf configuration file to be used by pacemaker, rgmanager must be disabled. The risk of not doing this is high; after a successful conversion, it would be possible to start rgmanager and pacemaker on the same host, managing the same resources. Consequently, Red Hat Enterprise Linux 6.2 includes a feature (as a Technology Preview) that forces the following requirements: rgmanager must refuse to start if it sees the <rm disabled="1"> flag in /etc/cluster.conf. rgmanager must stop any resources and exit if the <rm disabled="1"> flag appears in /etc/cluster.conf during a reconfiguration.
Story Points: ---
Clone Of:
: 917780 (view as bug list)
Environment:
Last Closed: 2011-12-06 06:59:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lon Hohberger 2011-07-21 11:00:37 EDT
Description of problem:

As a consequence of converting cluster.conf to be used by pacemaker, it is imperative that rgmanager be disabled.  The risk of not doing this is high; it means that, after a successful conversion, it would be possible to accidentally (or intentionally) start rgmanager *and* pacemaker on the same host, managing the same resources.

Consequently, a feature is proposed which has the following requirements:

* rgmanager must refuse to start if it sees a particular flag in cluster.conf.
* rgmanager must stop any resources and exit if this particular flag appears in cluster.conf during a reconfiguration.

The proposed feature flag (in cluster.conf) is:

   <rm disabled="1" ... />

This requires a tiny update to the cluster schema as well.
Comment 4 Lon Hohberger 2011-08-01 16:28:05 EDT
After adding 'disabled="1"' to cluster.conf, the following occurred:

node1:
Aug  1 16:23:39 snap modcluster: Updating cluster.conf
Aug  1 16:23:41 snap corosync[4620]:   [QUORUM] Members[2]: 1 2
Aug  1 16:23:41 snap rgmanager[12407]: Resource Group Manager Disabled
Aug  1 16:23:41 snap rgmanager[12407]: Shutting down
Aug  1 16:23:41 snap rgmanager[12407]: Stopping service service:1
Aug  1 16:23:41 snap rgmanager[12407]: Member 2 shutting down
Aug  1 16:23:41 snap rgmanager[12407]: Stopping service service:dang
Aug  1 16:23:41 snap rgmanager[14427]: [script] Executing /root/uhoh stop
Aug  1 16:23:42 snap rgmanager[14438]: [ip] Removing IPv4 address 192.168.122.201/24 from eth0
Aug  1 16:23:42 snap rgmanager[12407]: Service service:dang is stopped
Aug  1 16:23:52 snap rgmanager[14502]: [nfsclient] Removing export: *:/mnt/gfs2
Aug  1 16:23:53 snap rgmanager[14596]: [fs] unmounting /mnt/gfs2
Aug  1 16:23:53 snap rgmanager[12407]: Service service:1 is stopped
Aug  1 16:23:54 snap rgmanager[12407]: Disconnecting from CMAN
Aug  1 16:24:09 snap rgmanager[12407]: Exiting

node2:
Aug  1 16:23:39 crackle modcluster: Updating cluster.conf
Aug  1 16:23:40 crackle corosync[1918]:   [QUORUM] Members[2]: 1 2
Aug  1 16:23:41 crackle rgmanager[2274]: Resource Group Manager Disabled
Aug  1 16:23:41 crackle rgmanager[2274]: Shutting down
Aug  1 16:23:41 crackle rgmanager[2274]: Disconnecting from CMAN
Aug  1 16:23:41 crackle rgmanager[2274]: Exiting

When I tried to restart rgmanager:
[root@snap ~]# service rgmanager start
Starting Cluster Service Manager: rgmanager disabled in configuration; not starting
                                                           [FAILED]

[root@snap ~]# rpm -q rgmanager
rgmanager-3.0.12.1-3.el6.x86_64
Comment 5 Lon Hohberger 2011-08-01 16:37:41 EDT
Starting rgmanager after starting cman (but before quorum was attained) had the same behavior (error while running initscript)

Starting rgmanager before starting cman netted with rgmanager dead, but no messages.  (However, this is a "don't care" case.)
Comment 11 Lon Hohberger 2011-09-28 16:49:28 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
It is now possible to disable rgmanager in cluster.conf by adding disabled="1" to the <rm> tag.  Adding this to cluster.conf will cause rgmanager to refuse to run, and any instance of rgmanager currently running will shut down services and exit.  This feature is offered as a Technology Preview to assist users wishing to run the Pacemaker Cluster Resource Manager (which is also a Technology Preview) to prevent two resource managers from running at the same time.
Comment 12 Martin Prpic 2011-11-10 08:10:48 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1,5 @@
-It is now possible to disable rgmanager in cluster.conf by adding disabled="1" to the <rm> tag.  Adding this to cluster.conf will cause rgmanager to refuse to run, and any instance of rgmanager currently running will shut down services and exit.  This feature is offered as a Technology Preview to assist users wishing to run the Pacemaker Cluster Resource Manager (which is also a Technology Preview) to prevent two resource managers from running at the same time.+As a consequence of converting the /etc/cluster.conf configuration file to be used by pacemaker, rgmanager must be disabled. The risk of not doing this is high; after a successful conversion, it would be possible to start rgmanager and pacemaker on the same host, managing the same resources.
+Consequently, Red Hat Enterprise Linux 6.2 includes a feature (as a Technology Preview) that forces the following requirements:
+
+    rgmanager must refuse to start if it sees the <rm disabled="1"> flag in /etc/cluster.conf.
+    rgmanager must stop any resources and exit if the <rm disabled="1"> flag appears in /etc/cluster.conf during a reconfiguration.
Comment 13 errata-xmlrpc 2011-12-06 06:59:51 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1595.html

Note You need to log in before you can comment on or make changes to this bug.