Bug 72401 - factorized addresses don't work
Summary: factorized addresses don't work
Status: CLOSED DUPLICATE of bug 70504
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xinetd   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-23 14:46 UTC by Kirby
Modified: 2007-04-18 16:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-23 14:47:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kirby 2002-08-23 14:46:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
factorized addresses i.e. 192.168.0.{2,3,4} don't work
the error "Bad address: 192.168.0.{2,3,4}" is logged

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Assume you are 192.168.0.254 and the network is 192.168.0.0/24
2.Configure an xinetd service (wu-ftpd for example) for access control with a
factorized address "only_from = 192.168.0.{2,3,4}
3.restart xinetd
	

Actual Results:  the error message mentioned above is logged

Expected Results:  xinetd would only allow ftp connections from 192.168.0.2,
192.168.0.3, and 192.168.0.4.

Additional info:

Comment 1 Trond Eivind Glomsrxd 2002-08-23 19:43:44 UTC

*** This bug has been marked as a duplicate of 70504 ***


Note You need to log in before you can comment on or make changes to this bug.