Bug 72419 - "Extras" not great
"Extras" not great
Status: CLOSED DEFERRED
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-menus (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-23 12:29 EDT by Chris Parker
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-23 12:29:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Parker 2002-08-23 12:29:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
Not sure why there is a menu entry listed in GNOME as 'Extras' when the items in
'Extras' have the same layout as the main menu.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Login to GNOME
2.Browse menus
3.
	

Actual Results:  Confusing and illogical menu system that includes and 'Extras'
entry that has the same structure as the main menu.  I am not sure what makes
'Extras' extra.  It would be easier for me to find applications to run if I
didn't have to remember if the application was a 'game' or an 'extra/game'.

Expected Results:  Clean, logical menus that don't have me looking in two places
for the same item.

Additional info:

The menus in the null beta are much better than in 7.3, and it is nice to see
that all menu entries (including KDE) are in /usr/share/applications, but the
Linux world has never been known for its clean menu structure.  It would be
really nice to look in a section like games and find all of the games on my
system rather than having to hunt around.
Comment 1 Havoc Pennington 2002-08-23 12:41:48 EDT
Just not feasible, because putting Extras in the main menu makes the main menu
far too large. The problem to address is how to keep the menus fairly small and
sane.

I don't think Extras is a great solution. The right solution is probably "delete
duplicate or silly apps" but that would annoy people.

We'll be thinking about this long-term but closing bug as it's more of a big
vague project than a specific task to be tracked.
Comment 2 Chris Parker 2002-08-23 12:50:07 EDT
Why not use sub-menus?  Mandrake does a pretty good job of sepatating items, as
does Lycoris.

Either way, you guys do a much better job than Microsoft.  At least you don't
just throw everything on one big, fat menu.

Note You need to log in before you can comment on or make changes to this bug.