Bug 72436 - Unable to rhnpush source rpms
Unable to rhnpush source rpms
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
unspecified
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-23 14:55 EDT by Matt Jamison
Modified: 2007-07-31 15:26 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-27 17:34:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josef Komenda 2002-08-23 14:55:45 EDT
Description of Problem: Unable to rhnpush source rpms 

rhnpush -v --server=http://sat-inst.webdev-colo.redhat.com/APP -u sat-inst
 -c channel1 /etc/sysconfig/rhn/rhns-ca-cert-1.0-1.*

Channels: channel1
Red Hat Network password:
Connecting to http://sat-inst.webdev-colo.redhat.com/APP
Uploading package /etc/sysconfig/rhn/rhns-ca-cert-1.0-1.noarch.rpm

Error Message:
    Package upload failed: [Errno 13] Permission denied: '/var/satellite'
Error Class Code: 50
Error Class Info: Invalid information uploaded to the server
Explanation:
     An error has occurred while processing your request. If this problem
     persists please submit a bug report to rhn-help@redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.

Version-Release number of selected component (if applicable): see bug 63780

The error message is much improved, but it does not allow the .src.rpm to be
uploaded. You can confirm on sat-inst.
Comment 1 Josef Komenda 2002-08-23 16:07:07 EDT
Trying to push for these to get closed asap, so bumping to high priority.
Comment 2 Mihai Ibanescu 2002-08-23 19:17:34 EDT
Permissions problem?
Can you give me a ls -l on /var/satellite please?
Comment 3 Josef Komenda 2002-08-26 10:59:12 EDT
There is no /var/satellite/ 
in fact, there is no /satellite directory: 

[root@sat-inst root]# locate /satellite
/var/www/html/network/system/satellite.pxt
/var/www/html/network/systemlist/satellite_list.pxt
/var/www/html/rpc/satellite.pxt
/var/www/html/newlogin/satellite_finished.pxt
/var/www/rhns/satellite_tools
/var/www/rhns/satellite_tools/__init__.pyc
/var/www/rhns/satellite_tools/__init__.py
/var/www/rhns/satellite_tools/diskImportLib.py
/var/www/rhns/satellite_tools/diskImportLib.pyc
/var/www/rhns/satellite_tools/export.py
/var/www/rhns/satellite_tools/export.pyc
/var/www/rhns/satellite_tools/import_metadata.py
/var/www/rhns/satellite_tools/import_metadata.pyc
/var/www/rhns/satellite_tools/populate.py
/var/www/rhns/satellite_tools/populate.pyc
/var/www/rhns/satellite_tools/progress_bar.py
/var/www/rhns/satellite_tools/progress_bar.pyc
/var/www/rhns/satellite_tools/satsync.py
/var/www/rhns/satellite_tools/satsync.pyc
/var/www/rhns/satellite_tools/syncLib.py
/var/www/rhns/satellite_tools/syncLib.pyc
/var/www/rhns/satellite_tools/xmlDiskSource.py
/var/www/rhns/satellite_tools/xmlDiskSource.pyc
/var/www/rhns/satellite_tools/xmlImporter.py
/var/www/rhns/satellite_tools/xmlImporter.pyc
/var/www/rhns/satellite_tools/xmlSource.py
/var/www/rhns/satellite_tools/xmlSource.pyc
/var/www/rhns/satellite_tools/xmlWireSource.py
/var/www/rhns/satellite_tools/xmlWireSource.pyc
/etc/sysconfig/rhn-satellite-prep/satellite-rules.conf
/usr/bin/satellite-debug
/usr/bin/satellite-import
/usr/bin/satellite-sync
/usr/share/man/man8/satellite-import.8.gz
/usr/share/man/man8/satellite-sync.8.gz
/root/satellite-1.0.99.iso
Comment 4 Mihai Ibanescu 2002-08-26 12:07:19 EDT
Again, who was supposed to create /var/satellite? Isn't the installer supposed
to do that?

This is the directory where the import AND rhnpush will put packages; somebody
has to create it first 'cause rhnpush can't (since it runs as apache). I know
satellite-sync does, but I thought we said the satellite installer is gonna
create it instead.
Comment 5 Josef Komenda 2002-08-26 16:02:08 EDT
[root@sat-inst root]# mkdir /var/satellite
[root@sat-inst root]# chown apache.apache /var/satellite/
[root@sat-inst root]# rhnpush -v
--server=http://sat-inst.webdev-colo.redhat.com/APP -u sat-inst -c channel1
/etc/sysconfig/rhn/rhns-ca-cert-1.0-1.*
Channels: channel1
Red Hat Network password:
Connecting to http://sat-inst.webdev-colo.redhat.com/APP
Uploading package /etc/sysconfig/rhn/rhns-ca-cert-1.0-1.noarch.rpm
Uploading package /etc/sysconfig/rhn/rhns-ca-cert-1.0-1.src.rpm
Internal Server Error

Despite the 'Internal Server Error', it works - I can upload the package.
perhaps rhnpush should make the /var/satellite directory...
Comment 6 Mihai Ibanescu 2002-08-26 16:07:46 EDT
rhnpush can't, because it talks to an Apache service, which runs (of course) as
apache.apache.
Comment 7 Josef Komenda 2002-08-26 21:06:54 EDT
Ok, which package should handle this? Who should decide?
Comment 8 Josef Komenda 2002-08-28 13:19:47 EDT
Fixed - just make sure you load a channel first, or else:

  mkdir /var/satellite
  chown apache.apache /var/satellite

Note You need to log in before you can comment on or make changes to this bug.