Bug 72467 - php-4.1.2-7 errata shouldn't require imap
php-4.1.2-7 errata shouldn't require imap
Status: CLOSED DUPLICATE of bug 72007
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.3
All Linux
medium Severity high
: ---
: ---
Assigned To: Phil Copeland
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-23 21:35 EDT by Dax Kelson
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-23 21:44:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dax Kelson 2002-08-23 21:35:17 EDT
From Bugzilla Helper:  
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)  
  
Description of problem:  
php-imap SHOULD require imap, but php should not.  
  
# rpm -Fvh php-*  
error: failed dependencies:  
        freetype-devel >= 2.0.0 is needed by php-4.1.2-7.3.3  
        imap >= 2000-9 is needed by php-4.1.2-7.3.3  
        imap-devel >= 2000-9 is needed by php-4.1.2-7.3.3  
        mysql is needed by php-4.1.2-7.3.3  
        mysql-devel is needed by php-4.1.2-7.3.3  
        postgresql-devel is needed by php-4.1.2-7.3.3  
        ucd-snmp-devel is needed by php-4.1.2-7.3.3  
        unixODBC is needed by php-4.1.2-7.3.3  
        unixODBC-devel is needed by php-4.1.2-7.3.3  
  
Shouldn't imap* only be required by php-imap?  
  
This is causing me grief, since I'm using courier-imap (a high performance,  
and maildir capable POP3 & IMAP server).  
  
I don't have php-imap installed, I don't want it installed. But now I can't  
use up2date to install the errata. Everything worked fine with the php 
packages on RHL 7.3 cdroms. 
  
The Requires list is out-of-control. Why all the devel packages be needed?  
  
Version-Release number of selected component (if applicable):  
  
  
How reproducible:  
Always  
  
Steps to Reproduce:  
1. Examine Requires for php  
2. Notice how they haven't been granulized  
  
	  
  
Actual Results:  php requires many things it doesn't really need.  
  
Expected Results:    
  
Each individual php RPM, for example  
  
php-mysql  
php-ldap  
php-pgsql  
php-snmp  
php-imap  
  
Should have appropriate Requires for itself.  
  
Additional info:  
  
The devel packages for mysql, postgresql, etc shouldn't be required by php  
either.
Comment 1 Dax Kelson 2002-08-23 21:44:29 EDT
I did upgrade of php, php-ldap, php-pgsql with --nodeps  
  
You can see that imap isn't really required. 
 
[root@mail i386]# ldd /usr/lib/apache/libphp4.so  
        libpam.so.0 => /lib/libpam.so.0 (0x40196000)  
        libdl.so.2 => /lib/libdl.so.2 (0x4019f000)  
        libltdl.so.3 => /usr/lib/libltdl.so.3 (0x401a2000)  
        libpspell-modules.so.1 => /usr/lib/libpspell-modules.so.1 (0x401a9000)  
        libstdc++-libc6.2-2.so.3 => /usr/lib/libstdc++-libc6.2-2.so.3  
(0x401ab000)  
        libc.so.6 => /lib/i686/libc.so.6 (0x42000000)  
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x401ee000)  
        libpng.so.2 => /usr/lib/libpng.so.2 (0x4021c000)  
        libz.so.1 => /usr/lib/libz.so.1 (0x4023e000)  
        libcurl.so.2 => /usr/lib/libcurl.so.2 (0x4024c000)  
        libcrypto.so.2 => /lib/libcrypto.so.2 (0x4026b000)  
        libssl.so.2 => /lib/libssl.so.2 (0x4032f000)  
        libresolv.so.2 => /lib/libresolv.so.2 (0x4035c000)  
        libexpat.so.0 => /usr/lib/libexpat.so.0 (0x4036e000)  
        libmm.so.11 => /usr/lib/libmm.so.11 (0x4038d000)  
        libpspell.so.4 => /usr/lib/libpspell.so.4 (0x40392000)  
        libncurses.so.5 => /usr/lib/libncurses.so.5 (0x403ac000)  
        libgmp.so.3 => /usr/lib/libgmp.so.3 (0x403ea000)  
        libgd.so.1.8 => /usr/lib/libgd.so.1.8 (0x40412000)  
        libxml2.so.2 => /usr/lib/libxml2.so.2 (0x40445000)  
        libdb-3.3.so => /lib/libdb-3.3.so (0x404e8000)  
        libgdbm.so.2 => /usr/lib/libgdbm.so.2 (0x40577000)  
        libbz2.so.1 => /usr/lib/libbz2.so.1 (0x4057d000)  
        libm.so.6 => /lib/i686/libm.so.6 (0x4058d000)  
        libttf.so.2 => /usr/lib/libttf.so.2 (0x405af000)  
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x405da000)  
        libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0x40619000)  
        libnsl.so.1 => /lib/libnsl.so.1 (0x40637000)  
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)  
Comment 2 Phil Copeland 2002-08-26 14:35:33 EDT

*** This bug has been marked as a duplicate of 72007 ***

Note You need to log in before you can comment on or make changes to this bug.