Bug 72469 - php-4.1.2-7 errata shouldn't require postgresql
Summary: php-4.1.2-7 errata shouldn't require postgresql
Status: CLOSED DUPLICATE of bug 72007
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
Target Milestone: ---
Assignee: Phil Copeland
QA Contact: David Lawrence
Depends On:
TreeView+ depends on / blocked
Reported: 2002-08-24 08:45 UTC by Nicolas CROISET
Modified: 2007-04-18 16:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-08-26 16:46:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

Description Nicolas CROISET 2002-08-24 08:45:27 UTC
Description of Problem:
when I want to upgrade to the last release of PHP, php need dependancies for
postgresql. I don't want to use this package because I use mysql.

How Reproducible:
rpm -Uvh php-4.1.2-7.0.3.i386.rpm php-mysql-4.1.2-7.0.3.i386.rpm
error: failed dependencies:
        mysql-devel is needed by php-4.1.2-7.0.3
        postgresql is needed by php-4.1.2-7.0.3

Expected Results:
I don't think it's quiet good to need postgresql for php bu it's for
php-postgresql. I also does not understand wy php needs mysql-devel.

Comment 1 Need Real Name 2002-08-26 16:46:27 UTC
There are a *very* long list of "require"'s that seem to have suddenly shown up with the latest errata.  The 7.0 server I maintain (up to date with 
errata as of 08/19/2002) returned the following missing dependencies:

[root@rock i386]# rpm -Fvh --test php-*
error: failed dependencies:
        freetype-devel >= 1.3.1-7 is needed by php-4.1.2-7.0.3
        gmp-devel is needed by php-4.1.2-7.0.3
        imap-devel >= 2000-9 is needed by php-4.1.2-7.0.3
        mysql is needed by php-4.1.2-7.0.3
        mysql-devel is needed by php-4.1.2-7.0.3
        pspell-devel is needed by php-4.1.2-7.0.3
        ucd-snmp is needed by php-4.1.2-7.0.3
        ucd-snmp-utils is needed by php-4.1.2-7.0.3
        ucd-snmp-devel is needed by php-4.1.2-7.0.3
        unixODBC is needed by php-4.1.2-7.0.3
        unixODBC-devel is needed by php-4.1.2-7.0.3

A previous attempt to update PHP on another system (7.1/7.3 hybrid;  mostly up to date as of 08/19/2002) brought up a similar list:

[root@bacon i386]# rpm -Fvh --test php-*
error: failed dependencies:
        bzip2-devel >= 1.0 is needed by php-4.1.2-7.1.3
        db3-devel is needed by php-4.1.2-7.1.3
        freetype-devel >= 2.0.0 is needed by php-4.1.2-7.1.3
        gd-devel is needed by php-4.1.2-7.1.3
        gdbm-devel is needed by php-4.1.2-7.1.3
        gmp-devel is needed by php-4.1.2-7.1.3
        imap-devel >= 2000-9 is needed by php-4.1.2-7.1.3
        krb5-devel is needed by php-4.1.2-7.1.3
        libjpeg-devel is needed by php-4.1.2-7.1.3
        libpng-devel is needed by php-4.1.2-7.1.3
        ncurses-devel is needed by php-4.1.2-7.1.3
        postgresql is needed by php-4.1.2-7.1.3
        postgresql-devel is needed by php-4.1.2-7.1.3
        pspell-devel is needed by php-4.1.2-7.1.3
        ucd-snmp is needed by php-4.1.2-7.1.3
        ucd-snmp-utils is needed by php-4.1.2-7.1.3
        ucd-snmp-devel is needed by php-4.1.2-7.1.3
        unixODBC is needed by php-4.1.2-7.1.3
        unixODBC-devel is needed by php-4.1.2-7.1.3
        libltdl.so.0   is needed by php-4.1.2-7.1.3
        libpspell.so.2   is needed by php-4.1.2-7.1.3

RedHat 7.3 (up to date as of 08/19/2002) is similarly affected:

[root@filtermail i386]# rpm -Fvh --test php*
error: failed dependencies:
        bzip2-devel >= 1.0 is needed by php-4.1.2-7.3.3
        curl-devel >= 7.9.5 is needed by php-4.1.2-7.3.3
        db3-devel is needed by php-4.1.2-7.3.3
        expat-devel is needed by php-4.1.2-7.3.3
        freetype-devel >= 2.0.0 is needed by php-4.1.2-7.3.3
        gd-devel is needed by php-4.1.2-7.3.3
        gdbm-devel is needed by php-4.1.2-7.3.3
        gmp-devel is needed by php-4.1.2-7.3.3
        imap-devel >= 2000-9 is needed by php-4.1.2-7.3.3
        krb5-devel is needed by php-4.1.2-7.3.3
        libjpeg-devel is needed by php-4.1.2-7.3.3
        libpng-devel is needed by php-4.1.2-7.3.3
        libxml2-devel >= 2.4 is needed by php-4.1.2-7.3.3
        mm-develis needed by php-4.1.2-7.3.3
        mysql-devel is needed by php-4.1.2-7.3.3
        openssl-devel is needed by php-4.1.2-7.3.3
        pam-devel is needed by php-4.1.2-7.3.3
        postgresql-devel is needed by php-4.1.2-7.3.3
        pspell-devel is needed by php-4.1.2-7.3.3
        ucd-snmp is needed by php-4.1.2-7.3.3
        ucd-snmp-utils is needed by php-4.1.2-7.3.3
        ucd-snmp-devel is needed by php-4.1.2-7.3.3
        unixODBC-devel is needed by php-4.1.2-7.3.3
        zlib-devel is needed by php-4.1.2-7.3.3

Note that most of these dependencies appear to be "-devel" packages;  normally only required for actually *building* PHP.

None of the listed dependencies are wanted on *any* of these three particular systems.

Comment 2 Phil Copeland 2002-08-26 18:36:59 UTC
Full history and actions,...

*** This bug has been marked as a duplicate of 72007 ***

Note You need to log in before you can comment on or make changes to this bug.