Bug 72476 - (Savage) Screen corruption
(Savage) Screen corruption
Status: CLOSED DUPLICATE of bug 80346
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
Blocks: 82788
  Show dependency treegraph
Reported: 2002-08-24 06:43 EDT by Dumitru Ciobarcianu
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:49:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
XFree86 Config file in use (3.51 KB, text/plain)
2002-08-24 06:44 EDT, Dumitru Ciobarcianu
no flags Details
XFree86 log file (31.24 KB, text/plain)
2002-08-24 06:51 EDT, Dumitru Ciobarcianu
no flags Details

  None (edit)
Description Dumitru Ciobarcianu 2002-08-24 06:43:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
Vhen using gtk+1 apps the screen becomes corrupted.
It looks like it's "dirty". That I first thought it is so I carefully cleaned
the screen, but it was not the case. Cofee-coloured lines appear especially at
the end of the windows.
The corruption dissapears only on cold reboot.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Start an gtk1 app (galeon). I can always reproduce it using gcvs from
2.The screen becomes corrrupted
3.The problems becomes worse in time.

Actual Results:  Cofee-like colured dots and lines on the screen, especially at
the end of the windows.
The corruption becomes worse in time.

Expected Results:  No corruption

Additional info:

Using latest rawhide packages. (20020823)
The machine is an Toshiba Satellite Pro 4300.

I am also using the framebuffer with "vga=791 video=vesa:ywrap,mtrr" as kernel

The videocard entry in lspci -vvv: 

01:00.0 VGA compatible controller: S3 Inc. 86C270-294 Savage/IX-MV (rev 11)
(prog-if 00 [VGA])
        Subsystem: Toshiba America Info Systems: Unknown device 0001
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 248 (1000ns min, 63750ns max), cache line size 08
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at f0000000 (32-bit, non-prefetchable) [size=128M]
        Expansion ROM at 000c0000 [disabled] [size=64K]
        Capabilities: [dc] Power Management version 1
                Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [80] AGP version 1.0
                Status: RQ=31 SBA- 64bit- FW- Rate=x1,x2
                Command: RQ=0 SBA- AGP- 64bit- FW- Rate=<none>
Comment 1 Dumitru Ciobarcianu 2002-08-24 06:44:11 EDT
Created attachment 72724 [details]
XFree86 Config file in use
Comment 2 Dumitru Ciobarcianu 2002-08-24 06:51:40 EDT
Created attachment 72725 [details]
XFree86 log file
Comment 3 Mike A. Harris 2002-08-25 00:45:01 EDT
This is probably a video driver issue, and not likely a GTK problem,
however lets not rule out anything until we know better details.

Can you add the following to the Device section of your X config file:

Option "noaccel"

This is to test if it is a 2D acceleration bug or not.  If this option
makes the corruption go away, update the bug report letting me know
that, and we can then try some other tests to narrow it down, without
losing too much performance.
Comment 4 Dumitru Ciobarcianu 2002-08-25 19:53:42 EDT
No, disabling 2d acceleration does not help.
I can see the windows drawing slower but that's it.
Starting galeon and shuffling around the workspaces and moving the galeon window
makes the corruption reappear.
Comment 5 Mike A. Harris 2002-11-06 16:28:57 EST
Please attach a few screenshots showing this problem.
Comment 6 Dumitru Ciobarcianu 2002-11-09 07:20:47 EST
Odd. If I create an screenshot and view it on another machine it looks ok.
I'm beggining to suspect bad video ram or some other hardware problem.
Comment 7 Dumitru Ciobarcianu 2002-11-09 07:23:26 EST
One more note.
Now if I close all the windows in an workspace the corruption dissapears.
(Maybe because of screen repainting ?)
Comment 8 Mike A. Harris 2003-01-15 07:52:51 EST
Does disabling acceleration change anything?

This sounds like a gtk issue to me, or a buggy gtk theme.  It may be
hardware issue possibly like you suggest above as well.

The software 2D code in X has been around for ages and it functions identically
on all hardware.  If you've disabled 2D acceleration and still get this
problem, then I doubt it is XFree86 related.

It's been a while since this was reported.  By any chance have you observed
any changes, or acquired new data to update the report with before I
change status?
Comment 9 Mike A. Harris 2003-01-24 02:10:26 EST

*** This bug has been marked as a duplicate of 80346 ***
Comment 10 Red Hat Bugzilla 2006-02-21 13:49:29 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.