Bug 724784 - (BRMS-622) Saving package configuration breaks the package when ModeShape is used.
Saving package configuration breaks the package when ModeShape is used.
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: BRM (Guvnor), Modeshape (Show other bugs)
BRMS 5.2.0-Dev1
Unspecified Unspecified
high Severity urgent
: ---
: BRMS 5.2.0.GA
Assigned To: Kurt Stam
Jiri Locker
http://jira.jboss.org/jira/browse/BRM...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-09 05:23 EDT by Jiri Locker
Modified: 2011-08-19 01:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-09 10:58:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
error.png (4.98 KB, image/png)
2011-07-09 06:51 EDT, Jiri Locker
no flags Details
server.log (12.93 KB, text/plain)
2011-07-09 06:51 EDT, Jiri Locker
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker BRMS-622 Blocker Closed Saving package configuration breaks the package when ModeShape is used. 2013-10-30 15:45:42 EDT
JBoss Issue Tracker MODE-1217 Blocker Resolved Saving package configuration breaks the package when ModeShape is used. 2013-10-30 15:45:42 EDT

  None (edit)
Description Jiri Locker 2011-07-09 05:23:12 EDT
Steps to Reproduce: 1. Open package editor for any of the packages
2. Click File > Save changes
3. Open any rule in this package and try saving it. Fails with {{javax.jcr.ValueFormatException}}.
securitylevel_name: Public

See the attached server.log. Note, that I've logged in as "admin" and after I had imported the mortgages sample repo I saved the package configuration but the log contains {{USER:<anonymous> SAVING package [mortgages]}}. When Jackrabbit is used, the user name is logged correctly.
Comment 1 Jiri Locker 2011-07-09 06:15:51 EDT
Steps to Reproduce: Removed: 1. Open package editor for any of the packages
2. Click File > Save changes
3. Open any rule in this package and try saving it. Fails with Added: 1. Open package editor for any of the packages
2. Click File > Save changes
3. Open any rule in this package and try saving it. Fails with {{javax.jcr.ValueFormatException}}.
Comment 2 Jiri Locker 2011-07-09 06:51:13 EDT
Attachment: Added: error.png
Attachment: Added: server.log
Comment 3 Van Halbert 2011-07-10 23:55:11 EDT
Link: Added: This issue Cloned to BRMS-623
Comment 4 Len DiMaggio 2011-07-18 11:25:34 EDT
With which DB was this found?    Thx!
Comment 5 Jiri Locker 2011-07-19 02:48:05 EDT
Good question. It was only encountered with Derby DB -- other databases are blocked by BRMS-638.
Comment 6 Randall Hauch 2011-07-20 10:12:51 EDT
Also assigned to Kurt, as he's also looking into BRMS-638.
Comment 7 Randall Hauch 2011-07-20 10:13:16 EDT
Link: Added: This issue is related to BRMS-638
Comment 8 Jiri Locker 2011-08-09 10:58:22 EDT
Cannot reproduce with BRMS 5.2.0.ER2.

Note You need to log in before you can comment on or make changes to this bug.