Bug 724809 - subscription-manager repos --list probably need not require registration
subscription-manager repos --list probably need not require registration
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryan Kearney
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-07-21 16:57 EDT by John Sefler
Modified: 2011-12-06 12:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:22:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2011-07-21 16:57:57 EDT
Description of problem:
Currently, subscription-manager repos --list requires that you be registered before it can be called.

I suspect that this requirement is not necessary.


Version-Release number of selected component (if applicable):
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.4-1.git.47.e65faae.el6.x86_64


How reproducible:


Steps to Reproduce:
# subscription-manager unregister
This system is currently not registered.
# subscription-manager repos --list
Consumer not registered. Please register using --username and --password

^^^^
If this restriction is removed, then the expected output would be:
The system is not entitled to use any repositories.
Comment 1 Bryan Kearney 2011-07-22 10:00:32 EDT
Fixed in master at be369b5fdb9683a7fa93637794b5990eb9bb768f.
Comment 3 John Sefler 2011-07-25 17:05:48 EDT
Verifying Version...
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.4-1.git.54.5de26be.el6.x86_64

[root@jsefler-onprem-62server ~]# subscription-manager unregister
This system is currently not registered.
[root@jsefler-onprem-62server ~]# subscription-manager repos --list
The system is not entitled to use any repositories.

[root@jsefler-onprem-62server ~]# yum repolist
Loaded plugins: product-id, refresh-packagekit, subscription-manager
Updating certificate-based repositories.
repolist: 0

^^^^ Verified.  The system is not entitled to use any repositories, and in fact, the system has no enabled repos.
Comment 4 errata-xmlrpc 2011-12-06 12:22:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.