Bug 724847 - Zanata server assumes source pot is en-US
Zanata server assumes source pot is en-US
Status: CLOSED DUPLICATE of bug 707102
Product: Zanata
Classification: Community
Component: Component-PythonClient (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: zanata-dev-internal
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-21 21:00 EDT by Joshua Wulf
Modified: 2014-10-19 18:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-03 00:57:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2011-07-21 21:00:22 EDT
When I push a bunch of po files to the server for a project, if I don't have en-US set up as a language for the project, it fails.

The Zanata server assumes that the source lang for the pot is en-US.

If it's going to do that, then it should automatically add en-US to the project.

If it's not going to automatically add en-US then it shouldn't assume en-US and should ask me or require me to specify what the source language is.

It seems more consistent to either go all the way with the assumption or don't assume. 

The error message is confusing because it tells me that en-US is not supported, but I didn't specify en-US anywhere, nor does my pot specify en-US anywhere:


[jwulf@gaura po]$ zanata po push --import-po --srcdir .
Loading zanata/flies project config from from /home/jwulf/Work/anaconda/anaconda/po/zanata.xml
Loading zanata/flies user config from /home/jwulf/.config/zanata.ini
zanata/flies server: http://flies-devel.englab.bne.redhat.com
zanata python client version: 1.2.4, zanata/flies server API version: 1.3.1-SNAPSHOT
Project: anaconda
Version: rhel6
Username: jwulf
Source language: en-US
Copy previous translations:True
Importing translation
Importing translation from .
PO directory (originals):.

Pushing the content of ./anaconda.pot to server:
error: Unsupported Locale: en-US within this context. Please contact Admin.
Comment 1 Sean Flanigan 2011-09-07 00:33:39 EDT
Assigning to Scrum product owner for prioritisation.
Comment 2 Sean Flanigan 2012-07-03 00:57:09 EDT

*** This bug has been marked as a duplicate of bug 707102 ***

Note You need to log in before you can comment on or make changes to this bug.