Bug 724850 - RFE: print_unused images?
RFE: print_unused images?
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
future
Unspecified Unspecified
unspecified Severity unspecified
: 3.0
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On:
Blocks: 820023
  Show dependency treegraph
 
Reported: 2011-07-21 21:18 EDT by Stephen Gordon
Modified: 2012-10-30 23:11 EDT (History)
2 users (show)

See Also:
Fixed In Version: 3.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 23:11:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2011-07-21 21:18:17 EDT
Description of problem:

The command `publican print_unused` prints any and all xml files which are not linked into what publican would build, read they are orphaned. It would be useful if this functionality either extend to, or was available through an additional verb, for unreferenced image files.
Comment 1 Jeff Fearn 2011-10-10 09:44:48 EDT
Added print_unused_images action.

Added to branches/publican-2x and trunk.

Committed revision 1910.
Comment 2 Martin Prpic 2012-04-24 08:12:47 EDT
Verified with:

]$ rpm -q publican
publican-3.0-0.fc16.t166.noarch
]$ cat /etc/redhat-release 
Fedora release 16 (Verne)

Result:

Unused images (either unreferenced or commented out) are listed when "publican print_unused_images" is run.
Comment 3 Andrew Ross 2012-07-18 02:12:51 EDT
Reading bug 754340 and thought I'd check if print_unused_images works with <graphic> tags. It doesn't.


Setup:

1. Have image.svg in images.
$ ls en-US/images/
icon.svg  image.svg

2. Refn the image using a <graphic> tag.
$ grep "image.svg" en-US/Chapter.xml 
		<graphic fileref="image.svg" />

3. run print_unused_images
$ publican print_unused_images

List of unused Image files in en-US
    images/image.svg

List of missing Image files in en-US
    Common_Content/images/title_logo.svg


Note: tab completion also does not work with print_unused_images.
Comment 4 Jeff Fearn 2012-07-18 03:06:11 EDT
A: $ publican print_known  | grep -c graphic
0

Graphic is not a supported tag, it's ridiculous to fail it for this reason.

B: Tab completion works but because there are two very similar actions you have to get a long way along for it to know which one to pick.

C: Please stop wasting my time by causing churn on validated bugs.
Comment 5 Andrew Ross 2012-07-18 21:55:27 EDT
(In reply to comment #4)
> A: $ publican print_known  | grep -c graphic
> 0
> 
> Graphic is not a supported tag, it's ridiculous to fail it for this reason.
> 
> B: Tab completion works but because there are two very similar actions you
> have to get a long way along for it to know which one to pick.
> 
> C: Please stop wasting my time by causing churn on validated bugs.

Moving to verified.

Note You need to log in before you can comment on or make changes to this bug.