This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 72487 - RFE: Add support for disabling the duplicate IP check
RFE: Add support for disabling the duplicate IP check
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
: FutureFeature, Patch
Depends On:
Blocks: FC3BugWeekTracker
  Show dependency treegraph
 
Reported: 2002-08-24 09:25 EDT by Pekka Pietikäinen
Modified: 2014-03-16 22:30 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-13 05:48:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to allow disabiling the duplicate IP check and show offending MAC address (605 bytes, patch)
2003-10-26 07:19 EST, Pekka Pietikäinen
no flags Details | Diff
Updated version of the original patch (1.51 KB, patch)
2005-01-13 19:52 EST, Nicholas Miell
no flags Details | Diff

  None (edit)
Description Pekka Pietikäinen 2002-08-24 09:25:30 EDT
Description of Problem:

It would be useful in some situations, if it would be possible to disable
the duplicate IP check (or maybe warn about the situation but still
continue on). Also displaying the offending MAC address(es) would be useful.

Reason I need it is that my DSL runs PPPoE over some bridging LRE boxes
which means 192.168.0.1 etc. addresses might (and are) randomly get chosen by
some other user. Horribly broken, I know, but forcing the address (and statically
setting the arp entries + filtering out outside crap based on mac addresses)
works just fine until I get another ethernet card, which is the only good solution 
(or get the provider to configure their boxes correctly :) )
Comment 1 Pekka Pietikäinen 2003-10-26 07:17:54 EST
Solved this problem ages ago by getting another ethernet card, but
the feature still could be useful so here's a patch that does the trick
(a bit kludgy, I know, but my shell scripting is a bit rusty :-) ).

Actually the check as it is now is somewhat useless depending on how fast 
the adapter gets the link up after a ifconfig ethX up, since the arping
queries end up in /dev/null. (same problem as with DHCP, which is why there is a
check_link_down before the dhcp client gets run). 

For static addresses the extra delay required probably isn't worth it and
generally if the network is temporarily down and you have a static ip address,
you'd want things to automatically work when it does come back up.
You'd also want that users who don't know the difference between "IP address"
and "Router/DNS server IP address" can't DoS your router/DNS server when
it is booting (which is another scenario where the DUPLICATE_IP_CHECK=no 
option might be useful, although on such "hostile" networks switch port locking
is the way to go ;) ). 
Comment 2 Pekka Pietikäinen 2003-10-26 07:19:33 EST
Created attachment 95489 [details]
Patch to allow disabiling the duplicate IP check and show offending MAC address
Comment 3 Rik van Riel 2004-09-29 16:01:53 EDT
The patch makes sense.  Bill, any objections to having this patch
merged this bug week?   There appears to be zero risk in applying the
patch, since behaviour only changes if the system is configured for
changed behaviour...
Comment 4 Bill Nottingham 2004-09-29 16:19:01 EDT
a) magic config setting
b) non-translatable output string
Comment 5 Nicholas Miell 2005-01-13 19:52:01 EST
Created attachment 109755 [details]
Updated version of the original patch

This still has a magic config setting, but this time it's documented and the
string is translatable.
Comment 6 Rahul Sundaram 2005-11-24 15:34:55 EST
ping
Comment 7 Ian Pilcher 2007-02-23 18:13:38 EST
I just ran across this while setting up LVS with "direct routing."  Any chance
of getting this, along with another option to disable the later call to arping,
in?  If so, I'll gladly work up a patch.
Comment 8 John Poelstra 2008-07-02 15:21:49 EDT
Bill-what are your thoughts on this... patch is attached

Note You need to log in before you can comment on or make changes to this bug.