Bug 72490 - switching languages leaves menu in old language
switching languages leaves menu in old language
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: WindowMaker (Show other bugs)
8.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Havoc Pennington
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-24 10:11 EDT by Pedro Soria-Rodriguez
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-08 23:22:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pedro Soria-Rodriguez 2002-08-24 10:11:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020722

Description of problem:

(not really a WindowMaker problem... but I did not know which Component to select)

Not having logged in WindowMaker, I login with WindowMaker while my chosen
language is Chinese (simplified).  WindowMaker starts, with the app menu in chinese.

Then I log out.  Choose English (American) as the language for this session.  I
log in again into WindowMaker, but the window maker menu stays in Chinese (it
does not show the chinese characters, but it shows garbage chars, from the
chinese GB encoding)

A workaround is to delete the GNUstep directory from the home account before
loggin in again, so that it gets recreated with the menus in the newly chosen
language.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Simply follow my explanation above.
	

Additional info:
Comment 1 Phil Copeland 2002-08-26 14:50:57 EDT
Sounds like the enviroment variable (LANG or LOCALE) is not being reset. Sounds
like this would be an issue in Gnome or kde as well. The way you describe this
it sound like you're using the gdm and that it's not initializing the enviroment
correctly. Course, I could be wrong...

Phil
=--=

Comment 2 Pedro Soria-Rodriguez 2002-08-26 17:50:46 EDT
In the case of WindowMaker, I think what happens is that the WindowMaker menu
gets created in the user's directory, under GNUstep/ and if I switch the
language and log back in, the user menu file already exists, with all the menu
entries written in chinese GB encoding.   I guess there is no way to fix this,
because if the user has edited his menu, then the system cannot just change that
file, or else the user would lose his/her own manual changes.

And yes, I was using gdm (forgot to mention it in my original bug description)
Comment 3 Havoc Pennington 2004-08-08 23:22:46 EDT
WindowMaker has not been included for some time, closing bugs related to it.

Note You need to log in before you can comment on or make changes to this bug.