Bug 72494 - spanish accent marks and q (n with tilde) shown incorrectly.
spanish accent marks and q (n with tilde) shown incorrectly.
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-users (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Depends On:
  Show dependency treegraph
Reported: 2002-08-24 11:35 EDT by Pedro Soria-Rodriguez
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-05-25 10:31:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Screenshot showing the error displaying spanish accent marks. (53.87 KB, image/jpeg)
2002-08-24 11:36 EDT, Pedro Soria-Rodriguez
no flags Details
screenshot (48.90 KB, image/png)
2002-08-27 21:00 EDT, Brent Fox
no flags Details

  None (edit)
Description Pedro Soria-Rodriguez 2002-08-24 11:35:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020722

Description of problem:
My installation of (null) was done with Spanish as the default language.
When I created a user account during installation, the accent mark in the user
last name was shown correctly on screen.

Once the system booted, and I run redhat-config-users to add another user, I see
that the accent mark in the first user's name is shown incorrectly.  It ought to
be an "i" with an acute accent mark (like í in HTML) but instead see the
attached screenshot to see what it is displayed as.

The attached screenshot shows a shell window with the "finger" information for
the same user, correctly showing his name with the accent mark).

However, if I login remotely into the machine, and from that shell I finger the
same user (sorrodp), the accent mark is shown incorrectly, like in the
redhat-config-users application window.

Accent marks and spanish "q" (n with a tilde) are shown incorrectly in several
locations throughout the whole Red Hat Linux (null) installation.  The gdm
display also shows some of these characters incorrectly, in a similar fashion to
the error seen in the attached screenshot.

Version-Release number of selected component (if applicable):

How reproducible:
Didn't try

Additional info:
Comment 1 Pedro Soria-Rodriguez 2002-08-24 11:36:04 EDT
Created attachment 72764 [details]
Screenshot showing the error displaying spanish accent marks.
Comment 2 Brent Fox 2002-08-27 20:59:26 EDT
I don't know if this has been fixed since you tried Null or not, but this
doesn't seem to happen for me.  I have not specifically done anything to affect
the behavior, but perhaps something has changed in GTK that would have caused
the problem to go away?

I'm attaching a screenshot showing the current behavior.  Look at user "test12".
 The full name should have the Spanish accent marks on the "e" in Josi and the
"i" in Rodrmguez.

QA, please verify that the program handles accent chars correctly.
Comment 3 Brent Fox 2002-08-27 21:00:07 EDT
Created attachment 73426 [details]
Comment 4 Brent Fox 2002-08-27 21:01:30 EDT
Ah, Mozilla screwed up the chars in my previous post.  

Anyway, QA, please test with redhat-config-users-1.1-16.
Comment 5 Pedro Soria-Rodriguez 2002-08-29 04:18:44 EDT
I upgraded the package redhat-config-users to version 1.1-16.
The bug is still there.  That is, redhat-config-users still shows accent marks

I have a general idea about what may be wrong:
In your screenshot (redhat-config-users.py.png) I can see that you are using an
English environment.... that is, everything is in English.  The bug appears on a
Spanish installation of (null).  I did a Spanish install, choosing Spanish also
as the default language and the language for the root session (see my first

As I said earlier, when I typed the accent mark *during* the installation of the
distribution, at the point of choosing a root password and adding some users,
the accent mark was displayed correctly, but it is displayed incorrectly in any
graphical app once you are using the system.

Also, the GDM (again, in the Spanish installation), shows accented characters
incorrectly. (For instance the word "Session" is "Sesisn" in Spanish, with an
accent on the "o", and some weird char is shown instead of the "o" in GDM.

So, my take is that more than one Spanish character sets are being used in
different parts of the system such that there are different encodings for the
same character (let4s say an accented "o").   So when I type the "o" in one
application (the installer), it gets encoded with one character set.  Then
another app (for instance, redhat-config-users) reads the information but if it
is using a different character set, it will display some other char for that
same encoding.   

I believe that may be the reason why in my screenshot (accent_problem.jpg) you
see that the output of the "finger" command is corrent... the gnome terminal may
be using the same encoding that the installation application did, hence showing
the information correctly.   

However, if I ssh into this machine from machine "test", and in that shell I
type "finger sorrodp", then the wrong character is displayed... and it must be
because the encoding is wrong to begin with, since the machine "test" displays
all other spanish special characters correctly.

I guess this problem only shows up if you do an install in Spanish, since you
did not see the problem in your (apparently) English install of (null).

That4s what I think the problem may be.

If you do a Spanish install you will see that many (not all) menus in the gnome
desktop display accents as weird characters.  But other menus show the right
character for the same letter (for instance the accented "o").   That also makes
me think that the gnome-desktop uses one character set to display stuff on
screen, but different menu entries where encoded with different spanish
character sets, and that4s why some are displayed fine, and others are displayed

Comment 6 Brent Fox 2003-05-25 10:31:34 EDT
There is a stack of 64 bugs that have been in Modified state for a long period
of time.  I am closing these as Rawhide now.  If you find that the issue is not
fixed, please reopen this report.

Note You need to log in before you can comment on or make changes to this bug.