This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 724952 - [abrt] kernel: [ INFO: possible recursive locking detected ]
[abrt] kernel: [ INFO: possible recursive locking detected ]
Status: CLOSED DUPLICATE of bug 722472
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:9287dba136957e3ec176e1032f7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-22 08:15 EDT by Mads Kiilerich
Modified: 2011-07-22 11:06 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-22 11:06:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2011-07-22 08:15:02 EDT
abrt version: 2.0.3
cmdline:        ro root=/dev/mapper/VolGroup-lv_root16 rd_LVM_LV=VolGroup/lv_root16 rd_LVM_LV=VolGroup/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet
comment:        happens on boot
kernel:         undefined
reason:         [ INFO: possible recursive locking detected ]
time:           Fri Jul 22 14:12:07 2011

backtrace:
:[ INFO: possible recursive locking detected ]
:3.0-0.rc7.git3.1.fc16.i686.PAE #1
:---------------------------------------------
:systemd-logind/846 is trying to acquire lock:
: (&ep->mtx){+.+.+.}, at: [<c0533965>] ep_scan_ready_list+0x32/0x154
:but task is already holding lock:
: (&ep->mtx){+.+.+.}, at: [<c0533e04>] sys_epoll_ctl+0x103/0x481
:other info that might help us debug this:
: Possible unsafe locking scenario:
:       CPU0
:       ----
:  lock(&ep->mtx);
:  lock(&ep->mtx);
: *** DEADLOCK ***
: May be due to missing lock nesting notation
:2 locks held by systemd-logind/846:
: #0:  (epmutex){+.+.+.}, at: [<c0533dbf>] sys_epoll_ctl+0xbe/0x481
: #1:  (&ep->mtx){+.+.+.}, at: [<c0533e04>] sys_epoll_ctl+0x103/0x481
:stack backtrace:
:Pid: 846, comm: systemd-logind Not tainted 3.0-0.rc7.git3.1.fc16.i686.PAE #1
:Call Trace:
: [<c085e219>] ? printk+0x2d/0x2f
: [<c0472eab>] __lock_acquire+0x805/0xb57
: [<c040e02b>] ? sched_clock+0x8/0xb
: [<c0464d58>] ? sched_clock_local+0x10/0x18b
: [<c0533965>] ? ep_scan_ready_list+0x32/0x154
: [<c0473611>] lock_acquire+0xad/0xe4
: [<c0533965>] ? ep_scan_ready_list+0x32/0x154
: [<c0865ae5>] __mutex_lock_common+0x49/0x2ee
: [<c0533965>] ? ep_scan_ready_list+0x32/0x154
: [<c043a71c>] ? __might_sleep+0x29/0xfb
: [<c04724da>] ? mark_lock+0x26/0x1f2
: [<c0865ea4>] mutex_lock_nested+0x43/0x49
: [<c0533965>] ? ep_scan_ready_list+0x32/0x154
: [<c0533965>] ep_scan_ready_list+0x32/0x154
: [<c053353f>] ? ep_remove+0x9b/0x9b
: [<c0533a9b>] ep_poll_readyevents_proc+0x14/0x16
: [<c053374a>] ep_call_nested.constprop.2+0x6d/0x9a
: [<c0533a87>] ? ep_scan_ready_list+0x154/0x154
: [<c0533846>] ep_eventpoll_poll+0x45/0x55
: [<c0533f00>] sys_epoll_ctl+0x1ff/0x481
: [<c053366f>] ? ep_send_events_proc+0xd5/0xd5
: [<c086d49f>] sysenter_do_call+0x12/0x38
Comment 1 Michal Schmidt 2011-07-22 11:06:28 EDT

*** This bug has been marked as a duplicate of bug 722472 ***

Note You need to log in before you can comment on or make changes to this bug.