This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 725 - Kernel: Corrupt Freelist
Kernel: Corrupt Freelist
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
5.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-01-07 03:20 EST by lefty
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-05-31 15:32:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lefty 1999-01-07 03:20:17 EST
Machine: AMD K6-2 300MHz 64 MB RAM
Kernel 2.0.36-0.7 & 2.0.36-3
Sound card Yamaha Opl3Sax
kernel hangs when I do :
#rec - (rec from the sox package)
#cat /dev/audio is OK
#cat /dev/dsp is OK
#rec /tmp/somefile is OK
The message states:
Kernel: Free page list corrupt (or some such I am typing
offline)

The system is then dead, keyboard activity is ok but no disk
access at all.

A hard reset is needed.

Also I can send data to an external MIDI keyboard but I
cannot read from it. The commecial OSS drivers both read and
write to the external midi port.

E. Lefty Kreouzis
Comment 1 Bill Nottingham 1999-01-07 11:18:59 EST
The OPL3-SAX driver included in 2.0.36 is the very first version
of the driver; it may still have some problems. If you're willing
to try one of the 2.2.0pre kernels, that might solve the problem.
Comment 2 lefty 1999-01-25 02:39:59 EST
I installed 2.2.0-pre5-ac1 and the
kernel: VFS corrupt free list disapeared. however
I still cannot read midi data from an external keyboard I have.
I can play to the external midi keyboard OK.
When I tried the commercial OSS drivers I could both write to
and read to the external midi keyboard.
Maybe I should submit this as a different bug?
Comment 3 Daniel Senie 1999-02-17 14:43:59 EST
I get corrupt freelist problems with zillions of messages on the
console and a General Protection Fault in the syslog on one of my
key production servers. It crashed twice in the last 24 hours, once
so badly I had to run fsck by hand. I'll try to paste in the stuff
from /var/log/messages below.

System is an Intel 440BX2 motherboard, PII-350MHz, 64MB RAM. While
there is a sound card on this system, it is not in use (this is a
server, nobody's nearby to listen to music).

This hardware replaced a Pentium 133 running RHL 4.2 which ran without
flaws for over a year (250 days without a reboot).

The kernel is 2.0.36-3. My other servers running 2.0.36-1 have not
experienced similar problems, but do not face as much stress. The
system that keeps crashing runs qmail and handles large lists. It
seems like whenever it has to start paging a lot, it freaks out badly.

Feb 17 06:04:16 peanut kernel: general protection: 0000
Feb 17 06:04:16 peanut kernel: CPU:    0
Feb 17 06:04:16 peanut kernel: EIP:    0010:[dcache_add+97/404]
Feb 17 06:04:16 peanut kernel: EFLAGS: 00010286
Feb 17 06:04:16 peanut kernel: eax: 00023801   ebx: 00940400   ecx:
03c60301   edx: c95b2c28
Feb 17 06:04:16 peanut kernel: esi: 00940301   edi: 00940400   ebp:
001ecd14   esp: 03252ec4
Feb 17 06:04:16 peanut kernel: ds: 0018   es: 0018   fs: 002b   gs:
002b   ss: 0018
Feb 17 06:04:16 peanut kernel: Process tar (pid: 23945, process nr:
33, stackpage=03252000)
Feb 17 06:04:16 peanut kernel: Stack: 03c6689c 03c668a4 bfffeca0
000000b0 bfff0301 00150301 0015c01d 00940400
Feb 17 06:04:16 peanut kernel:        03c668a4 00000009 00023809
0235de58 00000f5d bfffeca0 bffffc28 03c6689c
Feb 17 06:04:16 peanut kernel:        03252f60 00000004 00000000
00000000 00000000 00000000 0011f451 03c668a4
Feb 17 06:04:16 peanut kernel: Call Trace: [raw_sendto+293/388]
[ext2_readdir+1149/1496] [kmalloc+169/512] [sys_getdents+150/200]
[filldir+0/164] [system_call+85/124]
Feb 17 06:04:16 peanut kernel: Code: 66 39 4a 08 75 30 8b 5c 24 1c 8b
43 04 39 42 0c 75 24 8b 43
Comment 4 Michael K. Johnson 1999-04-09 21:42:59 EDT
The second report from dts@senie.com is unrelated to the first
report and probably is an indication of a hardware problem.

Alan, do you know about any problems reading from a midi port
with the OPL3-SAX driver?  Has such a bug been fixed since this
was reported?

------- Email Received From  Alan Cox <alan@cymru.net> 04/09/99 22:09 -------

Note You need to log in before you can comment on or make changes to this bug.