Bug 725040 - rawhide installs generic-release package, instead of fedora-release
rawhide installs generic-release package, instead of fedora-release
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: generic-release (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F16Alpha/F16AlphaBlocker F16Alpha-accepted/F16AlphaFreezeExcept
  Show dependency treegraph
 
Reported: 2011-07-22 12:22 EDT by James Laska
Modified: 2013-09-02 02:57 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-03 20:53:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log (27.07 KB, text/plain)
2011-07-22 12:22 EDT, James Laska
no flags Details
install.log (64.34 KB, text/plain)
2011-07-22 12:22 EDT, James Laska
no flags Details
anaconda.yum.log (137.55 KB, text/plain)
2011-07-22 12:23 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2011-07-22 12:22:09 EDT
Created attachment 514734 [details]
anaconda.log

Description of problem:

After a @default install from RATs#3 images (http://serverbeach1.fedoraproject.org/pub/alt/stage/20110721-3/), it seems that generic-release was installed, instead of fedora-release.

Version-Release number of selected component (if applicable):
 * generic-release-16-0.1.noarch
 * fedora-release-16-0.1.noarch

How reproducible:


Steps to Reproduce:
1. Follow steps at https://fedoraproject.org/wiki/QA:Testcase_Package_Sets_Default_Package_Install
  
Actual results:

# grep release /tmp/install.log 
10:50:57 Installing generic-release-16-0.1.noarch

Expected results:

fedora-release should be installed, not generic-release

Additional info:

According to the yum.log from the install, generic-release is pulled in to satisfy a dependency for initscripts.

/tmp/anaconda.yum.log:[2011-07-22 10:48:44,068] DEBUG   : TSINFO: Marking generic-release-16-0.1.noarch as install for initscripts-9.31-1.fc16.x86_64

# repoquery -q --requires initscripts | grep release
/etc/system-release

# repoquery -q --whatprovides /etc/system-release
generic-release-0:16-0.1.noarch
generic-release-0:16-0.1.noarch
fedora-release-0:16-0.1.noarch
fedora-release-0:16-0.1.noarch

This needs to be fixed for Alpha, I'm not quite certain of any particular release criteria [1] that are impacted by installing the wrong package.  We may choose to update the release criteria for Alpha to note that fedora-release *must* be installed, and not *generic-release*.

[1] https://fedoraproject.org/wiki/Fedora_16_Alpha_Release_Criteria
Comment 1 James Laska 2011-07-22 12:22:50 EDT
Created attachment 514735 [details]
install.log
Comment 2 James Laska 2011-07-22 12:23:12 EDT
Created attachment 514736 [details]
anaconda.yum.log
Comment 3 Adam Williamson 2011-07-22 14:06:58 EDT
I checked the live composes, and they have the same issue - generic-release is pulled instead of fedora-release. however, the same is *not* true of -logos and -release-notes. so you get generic-release, fedora-logos and fedora-release-notes. never seen that before. can't tell exactly why at present.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Tim Flink 2011-07-22 17:59:44 EDT
Discussed at the 2011-07-22 blocker bug review meeting. Accepted as NTH for Fedora 16 alpha but waiting to find out if the Fedora 16 artwork will be affected as well.

Accepted NTH, will revisit alpha blocker once we have more information.
Comment 5 Chris Lumens 2011-07-25 10:57:55 EDT
Didn't this end up getting fixed in one of the -release packages?
Comment 6 James Laska 2011-07-25 15:51:06 EDT
(In reply to comment #5)
> Didn't this end up getting fixed in one of the -release packages?

I *think* it was supposed to be fixed by the update generic-release-16-0.2 (http://koji.fedoraproject.org/koji/buildinfo?buildID=255100).  The thinking was that because generic-release had fewer dependencies than fedora-release, it was selected for install.

I can confirm that the addition of generic-release-16.0.2.  Let's move this to VERIFIED once we have someone other than me confirming.
Comment 7 Tim Flink 2011-07-28 17:00:25 EDT
(In reply to comment #4)
> Discussed at the 2011-07-22 blocker bug review meeting. Accepted as NTH for
> Fedora 16 alpha but waiting to find out if the Fedora 16 artwork will be
> affected as well.
> 
> Accepted NTH, will revisit alpha blocker once we have more information.

Fixing whiteboard to match earlier decision
Comment 8 Tim Flink 2011-07-29 13:26:32 EDT
Discussed in the 2011-07-29 blocker review meeting. A fix for this has been verified in a custom boot.iso but waiting for verification on TC1 before closing.
Comment 9 Adam Williamson 2011-08-03 20:53:50 EDT
Confirmed TC1 DVD image has fedora-release and no generic-release package, closing.

Note You need to log in before you can comment on or make changes to this bug.