Bug 725046 - questionable usage from subscription-manager orgs for a READ_ONLY user
questionable usage from subscription-manager orgs for a READ_ONLY user
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryan Kearney
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-07-22 12:52 EDT by John Sefler
Modified: 2011-12-06 12:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:22:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2011-07-22 12:52:50 EDT
Description of problem:
The help message for subscription-manager orgs -help says:
Display the orgs available for a user

Then when I run subscription-manager orgs --username=magoo --password=password I get :
magoo cannot register to any organizations.

What is questionable is the wording of the term "register" in the response.  In my call to orgs, I did not ask if the user could register, I simply asked it to "Display the orgs available for a user".


Possible solutions...
1. change the usage help to say:
Display the organizations to which a user has permission to register.

2. change the output from orgs to include the "access" value for the orgs to which this user has any defined role.  For example:
# subscription-manager orgs --username=magoo --password=password
+-------------------------------------------+
          magoo Organizations
+-------------------------------------------+

OrgName: 	Snow White               
OrgKey: 	snowwhite                
Access:         READ_ONLY

OrgName: 	Admin Owner              
OrgKey: 	admin  
Access:         READ_ONLY

OrgName: 	Donald Duck              
OrgKey: 	donaldduck
Access:         READ_ONLY



While solution 1 is simple, there is merit in the extra information implied in solution 2.  The fact that solution 2 displays orgs for which magoo has READ_ONLY access would justify why magoo cannot register using these orgs.


Version-Release number of selected component (if applicable):
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.4-1.git.50.9f8a6ae.el6.x86_64
Comment 1 Bryan Kearney 2011-08-02 14:26:03 EDT
Took the easy road of fixing the help text.

09a9a90547da8a1a7b5a48f77280dee1f825ed10

in master.
Comment 4 Shwetha Kallesh 2011-08-19 00:42:10 EDT
Moving the bug to verified..

The usage help now says :

Display the orgs against which a user can register a system.

RPM used:

subscription-manager-0.96.6-1.git.1.b3b3fce.el6.x86_64


Steps to reproduce :

subscription-manager orgs --help
Usage: subscription-manager orgs [OPTIONS]

Display the orgs against which a user can register a system
Comment 5 errata-xmlrpc 2011-12-06 12:22:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.