Bug 725144 - csh variant for setting LibreOffice SDK environment uses wrong syntax
csh variant for setting LibreOffice SDK environment uses wrong syntax
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-23 05:31 EDT by Ivan Romanov
Modified: 2011-09-06 20:11 EDT (History)
3 users (show)

See Also:
Fixed In Version: libreoffice-3.3.3.1-5.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-06 20:11:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (782 bytes, patch)
2011-07-23 05:31 EDT, Ivan Romanov
no flags Details | Diff

  None (edit)
Description Ivan Romanov 2011-07-23 05:31:13 EDT
Created attachment 514813 [details]
patch

Description of problem:
I use tcsh and when I do ./setsdkenv_unix.csh I get error

$ ./setsdkenv_unix.csh
OFFICE_BASE_HOME=/usr/lib64/libreoffice/basis3.3: Command not found.
OFFICE_BASE_HOME: Undefined variable.

I fix this problem have a look at my patch in attachments.
Also this pathc solving problem with brackets in if statement
Comment 1 Caolan McNamara 2011-07-25 06:00:40 EDT
looks like mixed bash/tcsh sell script. Personally I suggest just using the bash one
Comment 2 Caolan McNamara 2011-07-25 06:03:07 EDT
yeah, busted since 2009
Comment 3 Caolan McNamara 2011-07-25 06:08:49 EDT
will be in >= 3.3.3.1-4 if we do another update for F-15
Comment 4 Fedora Update System 2011-08-24 05:10:46 EDT
libreoffice-3.3.3.1-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libreoffice-3.3.3.1-5.fc15
Comment 5 Fedora Update System 2011-08-26 14:51:23 EDT
Package libreoffice-3.3.3.1-5.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.3.3.1-5.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/libreoffice-3.3.3.1-5.fc15
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2011-09-06 20:11:28 EDT
libreoffice-3.3.3.1-5.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.