Bug 725183 - qtwebkit compilation problem due to qt patch
qtwebkit compilation problem due to qt patch
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
15
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-23 15:23 EDT by Loïc Yhuel
Modified: 2011-08-11 19:27 EDT (History)
9 users (show)

See Also:
Fixed In Version: qt-4.7.3-8.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-08 21:34:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Loïc Yhuel 2011-07-23 15:23:08 EDT
Description of problem:
When compiling qtwebkit (trunk, ie git://git.webkit.org/WebKit.git), the QWeb* symbols are not exported in the libQtWebKit library.
It happens since QT_SHARED is not defined.

It is due to a patch in qt.spec :
%if "%{_qt4_libdir}" == "%{_libdir}"
  sed -i -e "s|^QMAKE_LIBDIR_QT.*=.*|QMAKE_LIBDIR_QT       =|" mkspecs/common/linux.conf
%endif
Without the "QMAKE_LIBDIR_QT = $$[QT_INSTALL_LIBS]", during Makefile generation, qmake doesn't have -L/usr/lib in QMAKE_LIBDIR_FLAGS.
While this is not a problem for the link command line, qmake doesn't load the libQt*.prl files where QT_SHARED is set.


Version-Release number of selected component (if applicable):
qt-devel-4.7.3-6.fc15.i686

How reproducible:
QT_SHARED define can be checked by generating a sample makefile

Steps to Reproduce:
mkdir tst
cd tst
touch tst.cpp
qmake-qt4 -project
qmake-qt4
  
Actual results:
In Makefile, "DEFINES = -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_CORE_LIB"

Expected results:
In Makefile, "DEFINES = -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED"
Comment 1 Rex Dieter 2011-07-23 17:26:26 EDT
Ah ha!  Thanks!  That line was in there because previously we ended up with -L/usr/lib being included even on 64 bit builds where that is obviously wrong.

If that's no longer the case, I'll be happy to remove it.
Comment 2 Rex Dieter 2011-07-23 17:41:11 EDT
for posterity, that previous issue was bug #230224

%changelog (rawhide)
* Sat Jul 23 2011 Rex Dieter <rdieter@fedoraproject.org> 1:4.8.0-0.6.beta1
- fix QMAKE_LIBDIR_QT, for missing QT_SHARED define (#725183)

%changelog (f14,f15)
* Sat Jul 23 2011 Rex Dieter <rdieter@fedoraproject.org> 1:4.7.3-8
- fix QMAKE_LIBDIR_QT, for missing QT_SHARED define (#725183)
Comment 3 Fedora Update System 2011-07-23 20:35:14 EDT
qt-4.7.3-8.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/qt-4.7.3-8.fc15
Comment 4 Fedora Update System 2011-07-25 10:59:38 EDT
qt-4.7.3-8.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/qt-4.7.3-8.fc14
Comment 5 Fedora Update System 2011-07-25 23:45:33 EDT
Package qt-4.7.3-8.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qt-4.7.3-8.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/qt-4.7.3-8.fc15
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2011-08-08 21:34:36 EDT
qt-4.7.3-8.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2011-08-11 19:27:09 EDT
qt-4.7.3-8.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.