Bug 725187 - gnome-shell crashes/hangs when I switch users
gnome-shell crashes/hangs when I switch users
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 697199
  Show dependency treegraph
 
Reported: 2011-07-23 16:08 EDT by Need Real Name
Modified: 2012-05-30 02:18 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-30 02:18:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace -f -s 250 CRASHED-GNOME-SHELL-PID 1 (9.97 KB, text/plain)
2011-07-29 14:57 EDT, Need Real Name
no flags Details
strace -f -s 250 CRASHED-GNOME-SHELL-PID 2 (14.25 KB, text/plain)
2011-07-29 14:58 EDT, Need Real Name
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 653833 None None None Never

  None (edit)
Description Need Real Name 2011-07-23 16:08:08 EDT
Description of problem:
If I switch users, sometimes gnome-shell crashes (i.e. hangs/becomes unusable) and I have to kill -9 -u USER

Version-Release number of selected component (if applicable):
gnome-shell-3.0.2-4.fc15.x86_64

How reproducible:
Every day.

Steps to Reproduce:
1. Switch users a couple or a few times
2.
3.
  
Actual results:
Desktop becomes unresponsive.

Expected results:
Desktop continues to behave as usual.

Additional info:
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
Comment 1 Need Real Name 2011-07-26 17:15:50 EDT
Two things that happen

Option 1: I can switch user, but the interface is unusable - I can type, but not interact with any windows or alt+tab. Moving the mouse to the top left of the screen does nothing.

Option 2: black screen instead of login prompt.
Comment 2 Need Real Name 2011-07-27 15:53:34 EDT
This is definitely a gnome shell problem. If I kill -9 gnome-shell, everything comes back to life.
Comment 3 Need Real Name 2011-07-29 14:57:40 EDT
Created attachment 515922 [details]
strace -f -s 250 CRASHED-GNOME-SHELL-PID 1
Comment 4 Need Real Name 2011-07-29 14:58:26 EDT
Created attachment 515923 [details]
strace -f -s 250 CRASHED-GNOME-SHELL-PID 2
Comment 5 Need Real Name 2011-07-29 15:03:49 EDT
Hopefully this strace will help.
Comment 6 Need Real Name 2011-08-21 14:19:08 EDT
Again:

Process 10647 attached with 6 threads - interrupt to quit
[pid 10762] read(40,  <unfinished ...>
[pid 10655] futex(0x138241c, FUTEX_WAIT_PRIVATE, 5, NULL <unfinished ...>
[pid 10654] restart_syscall(<... resuming interrupted call ...> <unfinished ...>
[pid 10653] restart_syscall(<... resuming interrupted call ...> <unfinished ...>
[pid 10652] restart_syscall(<... resuming interrupted call ...> <unfinished ...>
[pid 10647] restart_syscall(<... resuming interrupted call ...> <unfinished ...>
Comment 7 Need Real Name 2011-11-15 15:45:43 EST
Still the same problem with Fedora 16.

Switching from user1 to user2 works fine.
Switching back from user2 to user1 fails.

Xorg.0.log has this:

[398851.797] (II) AIGLX: Suspending AIGLX clients for VT switch

[398875.982] (II) AIGLX: Resuming AIGLX clients after VT switch
Comment 8 Need Real Name 2012-01-10 16:51:31 EST
Any chance of upping severity? I have to kill gdm and I lose my work.
Comment 9 cblaauw 2012-01-11 02:12:50 EST
I see the same here.

There are two different things that can happen if user switching fails:

a) the screen is completely black solution -> switch to another VT to find gdm, that is gdm is running fine, but the correct VT is not selected automatically. This does not happen very often.

b) gdm shows just one user entry picture and nothing else (no input fields etc.) and does not accept any input solution -> ctrl-alt-backspace restarts gdm on that particular VT. This does happen a lot more often than type a.

I think a is related to xorg and b is a problem of gnome-shell/gdm
Comment 10 Paul Howarth 2012-01-11 04:41:04 EST
(In reply to comment #9)
> I see the same here.
> 
> There are two different things that can happen if user switching fails:
> 
> a) the screen is completely black solution -> switch to another VT to find gdm,
> that is gdm is running fine, but the correct VT is not selected automatically.
> This does not happen very often.
> 
> b) gdm shows just one user entry picture and nothing else (no input fields
> etc.) and does not accept any input solution -> ctrl-alt-backspace restarts gdm
> on that particular VT. This does happen a lot more often than type a.
> 
> I think a is related to xorg and b is a problem of gnome-shell/gdm

Don't often see (a) but I see (b) regularly, having three users share a machine.
Comment 11 Need Real Name 2012-01-11 11:41:33 EST
A colleague of mine reports problem (a) on RHEL6. I haven't seen this very often in F16.

For (b) I see just a blue screen. The login chooser is missing.
Comment 12 Need Real Name 2012-01-19 12:09:59 EST
This bug seems to have disappeared! I will update in a week if it has gone.
Comment 13 Kanwar Ranbir Sandhu 2012-04-06 10:40:40 EDT
I've been having the exact same problem since Fedora 15, and it DEFINITELY has not disappeared.  It's infuriating - I see the bug several times every single day.

The one thing I can add is it appears to start after waking the PC a few times from a suspended state.  If I shutdown every night, I can switch users to my heart's content.  As soon as I've done a few suspend/wake cycles, the bug comes back.
Comment 14 Ray Strode [halfline] 2012-04-09 17:20:30 EDT
We fixed this upstream a while back, but I don't know if it's made it into an update.

The upstream bug report is here:

https://bugzilla.gnome.org/show_bug.cgi?id=653833
Comment 15 Need Real Name 2012-05-18 10:54:13 EDT
Could you please fix this bloody bug? gdm hanging while user switching. gdm can't be complicated, it's only doing one thing. Every single day I wonder why this bug is still open - it's nearly enough to make me switch to OS X!
Comment 16 Need Real Name 2012-05-30 02:18:59 EDT
F17: looks like you nailed it! Thanks!

Note You need to log in before you can comment on or make changes to this bug.