Bug 725242 - wording on "No such entitlement pool" message
wording on "No such entitlement pool" message
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Bryan Kearney
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-07-24 11:28 EDT by John Sefler
Modified: 2011-12-06 12:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:22:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2011-07-24 11:28:02 EDT
Description of problem:
When attempting to subscribe to a pool that does not exist, the error message is:
No such entitlement pool: 123

I believe this is the only place the term "entitlement pool" is used.  Most everywhere else we have called it a "subscription pool".

A more consistent error message would be:
Subscription pool '123' does not exist.


Version-Release number of selected component (if applicable):
# rpm -q subscription-manager
subscription-manager-0.96.4-1.git.54.5de26be.el6.x86_64


Steps to Reproduce:
# subscription-manager subscribe --pool=123
  
Actual results:
No such entitlement pool: 123

Expected results:
Subscription pool '123' does not exist.
Comment 1 Bryan Kearney 2011-07-26 14:27:56 EDT
Fixed in master in b04de4d516d9f6b1036248db29c23a7b1e577c97. New string is "Subscription pool {0} does not exist.
Comment 3 John Sefler 2011-07-26 17:09:29 EDT
Verifying Version...
[root@jsefler-onprem-62candlepin proxy]# git branch
  0.3
* master
[root@jsefler-onprem-62candlepin proxy]# git show-ref | grep master
b04de4d516d9f6b1036248db29c23a7b1e577c97 refs/heads/master
b04de4d516d9f6b1036248db29c23a7b1e577c97 refs/remotes/origin/master


[root@jsefler-onprem-62server ~]# subscription-manager register --username=testuser1 --password=password --org=admin
The system has been registered with id: 9175510f-410a-4e2a-8519-3c38fb8ad017 
[root@jsefler-onprem-62server ~]# subscription-manager subscribe --pool=123
Subscription pool 123 does not exist.
[root@jsefler-onprem-62server ~]# 

moving to VERIFIED
Comment 4 errata-xmlrpc 2011-12-06 12:22:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.