Bug 725250 - zarafa-admin --list-companies generates error
Summary: zarafa-admin --list-companies generates error
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: zarafa
Version: el5
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Robert Scheck
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-24 17:14 UTC by Erik M Jacobs
Modified: 2011-09-13 05:47 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-08-28 05:32:03 UTC


Attachments (Terms of Use)

Description Erik M Jacobs 2011-07-24 17:14:44 UTC
Description of problem:
When using the --list-companies command, an error is generated, but the command appears to list all companies successfully.

Version-Release number of selected component (if applicable):
zarafa-utils.x86_64 7.0.0-1.el5
(I also experience this behavior on i686)

How reproducible:
100%

Steps to Reproduce:
1. run "zarafa-admin --list-companies"
  
Actual results:
Example:
[root@atlas ~]# zarafa-admin --list-companies
Company list (3):
	Companyname	System administrator	
	-----------------------------------------
	Groups		SYSTEM	
	People		SYSTEM	
	Special Users	SYSTEM	
zarafa-admin: mapix.cpp:2664: ULONG MAPIFreeBuffer(void*): Assertion `0' failed.
Aborted

Expected results:
No error.

Comment 1 Robert Scheck 2011-07-26 14:59:38 UTC
Forwarded to upstream via e-mail. Did not yet receive a reference ID.

Comment 2 Robert Scheck 2011-07-27 23:43:46 UTC
Upstream reference for now is Ticket#2011072610000202. A Zarafa employee
will try to debug this issue together with a developer. This issue seems
only to show up in the Fedora build, not in the official builds. I assume
at the moment, that the issue exists due to more strict compiler flags at
Fedora. We had similar issues in the past already.

Comment 3 Robert Scheck 2011-07-29 13:51:51 UTC
Feedback from Zarafa was, that we should build using "--enable-release" at
%configure to avoid assertion errors at all. Will do so starting with Zarafa
6.40.10 and 7.0.1.

Comment 4 Fedora Update System 2011-07-30 01:03:52 UTC
zarafa-6.40.10-1.el4 has been submitted as an update for Fedora EPEL 4.
https://admin.fedoraproject.org/updates/zarafa-6.40.10-1.el4

Comment 5 Fedora Update System 2011-08-14 00:30:59 UTC
zarafa-7.0.1-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/zarafa-7.0.1-1.fc16

Comment 6 Fedora Update System 2011-08-14 00:31:43 UTC
zarafa-7.0.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/zarafa-7.0.1-1.fc15

Comment 7 Fedora Update System 2011-08-14 00:32:17 UTC
zarafa-7.0.1-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/zarafa-7.0.1-1.fc14

Comment 8 Fedora Update System 2011-08-14 00:32:47 UTC
zarafa-7.0.1-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/zarafa-7.0.1-1.el6

Comment 9 Fedora Update System 2011-08-14 00:33:26 UTC
php53-mapi-7.0.1-1.el5,zarafa-7.0.1-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/php53-mapi-7.0.1-1.el5,zarafa-7.0.1-1.el5

Comment 10 Fedora Update System 2011-08-15 20:26:42 UTC
Package zarafa-7.0.1-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing zarafa-7.0.1-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/zarafa-7.0.1-1.fc16
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2011-08-16 21:03:36 UTC
zarafa-6.40.10-1.el4 has been pushed to the Fedora EPEL 4 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2011-08-28 05:31:47 UTC
zarafa-7.0.1-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2011-09-13 02:28:59 UTC
zarafa-7.0.1-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2011-09-13 02:29:47 UTC
php53-mapi-7.0.1-1.el5, zarafa-7.0.1-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2011-09-13 05:44:41 UTC
zarafa-7.0.1-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2011-09-13 05:47:35 UTC
zarafa-7.0.1-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.