Bug 725256 - bind is disliked by logrotate
bind is disliked by logrotate
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-24 15:30 EDT by Michal Jaegermann
Modified: 2013-04-30 19:49 EDT (History)
4 users (show)

See Also:
Fixed In Version: dnsperf-1.0.1.0-25.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-23 00:02:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2011-07-24 15:30:35 EDT
Description of problem:

bind provides /etc/logrotate.d/named with the following content:

/var/named/data/named.run {
    missingok
    create 0644 named named
    postrotate
        /sbin/service named reload  2> /dev/null > /dev/null || true
    endscript
}

The current logrotate clearly dislikes that as an attempt to use the ends up with the following:

/etc/cron.daily/logrotate:

error: skipping "/var/named/data/named.run" because parent directory has insecure permissions (It's world writable or writable by group which is not "root") Set "su" directive in config file to tell logrotate which user/group should be used for rotation.

/var/named/data indeed is 'drwxrwx--- 2 named named'.

Version-Release number of selected component (if applicable):
bind-9.8.0-7.P4.fc16
logrotate-3.8.0-3.fc16
Comment 1 Michal Jaegermann 2011-08-18 15:01:28 EDT
This error still persists.  Is adding in /etc/logrotate.d/named a line which says

  su named named

a big trouble?
Comment 2 Kevin Fenzi 2011-08-28 11:38:52 EDT
I'm seeing this here too. A fix would be nice.
Comment 3 Andrew McNabb 2011-09-02 14:43:34 EDT
I am also experiencing this problem.
Comment 4 Fedora Update System 2011-09-09 07:29:37 EDT
dnsperf-1.0.1.0-25.fc16,dhcp-4.2.2-5.fc16,bind-dyndb-ldap-1.0.0-0.2.b1.fc16,bind-9.8.1-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/dnsperf-1.0.1.0-25.fc16,dhcp-4.2.2-5.fc16,bind-dyndb-ldap-1.0.0-0.2.b1.fc16,bind-9.8.1-2.fc16
Comment 5 Fedora Update System 2011-09-09 11:09:10 EDT
Package dnsperf-1.0.1.0-25.fc16, dhcp-4.2.2-5.fc16, bind-dyndb-ldap-1.0.0-0.2.b1.fc16, bind-9.8.1-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnsperf-1.0.1.0-25.fc16 dhcp-4.2.2-5.fc16 bind-dyndb-ldap-1.0.0-0.2.b1.fc16 bind-9.8.1-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/dnsperf-1.0.1.0-25.fc16,dhcp-4.2.2-5.fc16,bind-dyndb-ldap-1.0.0-0.2.b1.fc16,bind-9.8.1-2.fc16
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2011-09-23 00:02:18 EDT
dnsperf-1.0.1.0-25.fc16, dhcp-4.2.2-5.fc16, bind-dyndb-ldap-1.0.0-0.2.b1.fc16, bind-9.8.1-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.