Bug 725267 - Review Request: qodem - Qodem terminal emulator and communications package
Summary: Review Request: qodem - Qodem terminal emulator and communications package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mario Blättermann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: qodem (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-24 22:29 UTC by Richard Shaw
Modified: 2014-05-20 18:32 UTC (History)
4 users (show)

Fixed In Version: qodem-0.3.2-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-09 01:28:28 UTC
mario.blaettermann: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Richard Shaw 2011-07-24 22:29:56 UTC
Spec URL: http://hobbes1069.fedorapeople.org/qodem/qodem.spec
SRPM URL: http://hobbes1069.fedorapeople.org/qodem/qodem-0.3.2-1.fc14.src.rpm
Description:
Qodem is an open-source re-implementation of the Qmodem(tm)
shareware communications package, updated for more modern uses.
Major features include:
    * Unicode display: translation of CP437 (PC VGA), VT100 DEC
      Special Graphics characters, VT220 National Replacement
      Character sets, etc., to Unicode
    * Terminal interface conveniences: scrollback buffer, capture
      file, screen dump, dialing directory, keyboard macros, script
      support
    * Connection methods: serial, local shell, command line, telnet,
      ssh, rlogin, rsh
    * Emulations: ANSI.SYS (including "ANSI music"), Avatar, VT52,
      VT100/102, VT220, Linux, and XTerm
    * Transfer protocols: Xmodem, Ymodem, Zmodem, and Kermit

Comment 1 Richard Shaw 2011-07-24 22:31:04 UTC
Rpmlint output:

$ rpmlint *.rpm
qodem.src: W: name-repeated-in-summary C Qodem
qodem.src: W: spelling-error %description -l en_US tm -> TM, mt, Tm
qodem.src: W: spelling-error %description -l en_US scrollback -> sc rollback, sc-rollback, scroll back
qodem.src: W: spelling-error %description -l en_US rlogin -> login, r login, logging
qodem.src: W: spelling-error %description -l en_US rsh -> rah, rs, sh
qodem.src: W: spelling-error %description -l en_US Xmodem -> Modem, X modem, Demode
qodem.x86_64: W: name-repeated-in-summary C Qodem
qodem.x86_64: W: spelling-error %description -l en_US tm -> TM, mt, Tm
qodem.x86_64: W: spelling-error %description -l en_US scrollback -> sc rollback, sc-rollback, scroll back
qodem.x86_64: W: spelling-error %description -l en_US rlogin -> login, r login, logging
qodem.x86_64: W: spelling-error %description -l en_US rsh -> rah, rs, sh
qodem.x86_64: W: spelling-error %description -l en_US Xmodem -> Modem, X modem, Demode
qodem.x86_64: E: incorrect-fsf-address /usr/share/doc/qodem-0.3.2/COPYING
qodem-debuginfo.x86_64: E: incorrect-fsf-address /usr/src/debug/qodem-0.3.2/getopt.h
3 packages and 0 specfiles checked; 2 errors, 12 warnings.

I have reported the incorrect FSF address upstream.

Comment 2 Richard Shaw 2011-07-24 22:32:09 UTC
*** Bug 474012 has been marked as a duplicate of this bug. ***

Comment 3 Mario Blättermann 2011-07-25 19:23:09 UTC
Koji scratch build for F15:
http://koji.fedoraproject.org/koji/taskinfo?taskID=3228372

The output of rpmlint is almost OK. Spelling errors could be ignored. There's an incorrect FSF address in some files, but if you have reported the bug upstream (and upstream is responsible) you may leave the appropriate files untouched for the time being.

Please change the summary so that it doesn't include the package name. Not a blocker, but would be nice to make rpmlint happy again...

You was forgotten to add the documentation files. Please add AUTHORS, ChangeLog, COPYING, CREDITS, NEWS, README and TODO to your package.

---------------------------------
key:

[+] OK
[.] OK, not applicable
[X] needs work
---------------------------------

[+] MUST: The package must be named according to the Package Naming Guidelines.
[+] MUST: The spec file name must match the base package %{name}.
[+] MUST: The package must meet the Packaging Guidelines.
[+] MUST: The package must be licensed with a Fedora approved license.
    GPLv2+
[+] MUST: The License field in the package spec file must match the actual
license.
[X] MUST: The file containing the text of the license(s) for the package must
be included in %doc.
[+] MUST: The spec file must be written in American English.
    "Spelling errors" are ignoreable.

[+] MUST: The spec file for the package MUST be legible.
[+] MUST: The sources used to build the package must match the upstream source.
    $ md5sum *
    36f0effbde999f7138eb94d773c0412d  qodem-0.3.2.tar.gz
    36f0effbde999f7138eb94d773c0412d  qodem-0.3.2.tar.gz.packaged

[+] MUST: The package MUST successfully compile and build into binary rpms on
at least one primary architecture.
- See Koji build above.
[.] MUST: If the package does not successfully compile, build or work on an
architecture, ...
[+] MUST: All build dependencies must be listed in BuildRequires.
[+] MUST: The spec file MUST handle locales properly.
[.] MUST: If a package installs files below %{_datadir}/icons, the icon cache
must be updated.
[.] MUST: Packages storing shared library files (not just symlinks) must call
ldconfig in %post and %postun.
[.] MUST: Packages must NOT bundle copies of system libraries.
[.] MUST: If the package is designed to be relocatable, ...
[+] MUST: A package must own all directories that it creates. 
[+] MUST: A Fedora package must not list a file more than once in %files.
[+] MUST: Permissions on files must be set properly.
[+] MUST: Packages must not provide RPM dependency information when that
information is not global in nature, or are otherwise handled.
[.] MUST: When filtering automatically generated RPM dependency information,
the filtering system implemented by Fedora must be used.
[+] MUST: Each package must consistently use macros.
[+] MUST: The package must contain code, or permissable content.
[.] MUST: Large documentation files must go in a -doc subpackage.
[+] MUST: Files in %doc must not affect the runtime of the application.
[.] MUST: Header files must be in a -devel package.
[.] MUST: Static libraries must be in a -static package.
[.] MUST: If a package contains library files with a suffix (e.g.
libfoo.so.1.1), ...
[.] MUST: devel packages must require the base package using a fully versioned
dependency.
[.] MUST: Packages must NOT contain any .la libtool archives.
[+] MUST: Packages containing GUI applications must include a %{name}.desktop
file
[+] MUST: .desktop files must be properly installed with desktop-file-install
in the %install section.
[+] MUST: Packages must not own files or directories already owned by other
packages.
[+] MUST: All filenames in rpm packages must be valid UTF-8.

[.] SHOULD: If the source package does not include license text(s) as a
    separate file from upstream, the packager SHOULD query upstream...

[+] SHOULD: Timestamps of files should be preserved.
[+] SHOULD: The reviewer should test that the package builds in mock.
    See Koji build above (which uses mock anyway)
[+] SHOULD: The reviewer should test that the package functions as described.
    I assume the packager has tested it.
[.] SHOULD: If scriptlets are used, those scriptlets must be sane.
[.] SHOULD: Usually, subpackages other than devel should require the base
package using a fully versioned dependency.
[.] SHOULD: pkgconfig(.pc) files should be placed in a -devel pkg.
[.] SHOULD: If the package has file dependencies outside of /etc, /bin, /sbin,
/usr/bin, or /usr/sbin ...
[+] SHOULD: Your package should contain man pages for binaries/scripts.

Comment 4 Mario Blättermann 2011-07-25 19:37:20 UTC
...Forget about what I wrote about the wrote about the docs. I've swapped the tabs in gedit by accidence, sorry...

Comment 5 Mario Blättermann 2011-07-25 19:40:07 UTC
That's why, this package is

APPROVED.

Please don't forget to tweak the summary before feeding the Git.

Comment 6 Richard Shaw 2011-07-25 19:48:11 UTC
(In reply to comment #4)
> ...Forget about what I wrote about the wrote about the docs. I've swapped the
> tabs in gedit by accidence, sorry...

I was actually missing a couple of them, so thanks!

(In reply to comment #3)
> Please change the summary so that it doesn't include the package name. Not a
> blocker, but would be nice to make rpmlint happy again...

Fixed... I actually copied that from the old review request... 

Thanks!
Richard

Comment 7 Richard Shaw 2011-07-25 19:50:19 UTC
New Package SCM Request
=======================
Package Name: qodem
Short Description: Terminal emulator and communications package
Owners: hobbes1069
Branches: f14 f15 el6
InitialCC:

Comment 8 Gwyn Ciesla 2011-07-26 01:56:34 UTC
Git done (by process-git-requests).

Comment 9 Fedora Update System 2011-07-26 13:31:26 UTC
qodem-0.3.2-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/qodem-0.3.2-1.el6

Comment 10 Fedora Update System 2011-07-26 13:31:34 UTC
qodem-0.3.2-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/qodem-0.3.2-1.fc15

Comment 11 Fedora Update System 2011-07-26 13:31:44 UTC
qodem-0.3.2-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/qodem-0.3.2-1.fc14

Comment 12 Jeff Gustafson 2011-07-26 20:17:45 UTC
I was contacted by the author of the program awhile ago. I exchanged a couple of emails, but then nothing. I'm glad to see someone packaged this application.

Comment 13 Fedora Update System 2011-07-30 10:40:41 UTC
qodem-0.3.2-1.el6 has been pushed to the Fedora EPEL 6 testing repository.

Comment 14 Fedora Update System 2011-08-09 01:28:21 UTC
qodem-0.3.2-1.fc15 has been pushed to the Fedora 15 stable repository.

Comment 15 Fedora Update System 2011-08-09 01:35:15 UTC
qodem-0.3.2-1.fc14 has been pushed to the Fedora 14 stable repository.

Comment 16 Richard Shaw 2011-08-16 18:28:30 UTC
Package Change Request
======================
Package Name: qodem
New Branches: f16
Owners: hobbes1069
InitialCC: 

Missed branching for F16.

Comment 17 Gwyn Ciesla 2011-08-16 18:56:39 UTC
f16 exists.

Comment 18 Richard Shaw 2011-08-16 19:05:02 UTC
Sorry, should have tried a git pull first.

Comment 19 Fedora Update System 2011-08-16 20:57:19 UTC
qodem-0.3.2-1.el6 has been pushed to the Fedora EPEL 6 stable repository.

Comment 20 Richard Shaw 2014-05-20 18:19:46 UTC
Package Change Request
======================
Package Name: qodem
New Branches: epel7
Owners: hobbes1069
InitialCC:

Comment 21 Gwyn Ciesla 2014-05-20 18:32:24 UTC
Git done (by process-git-requests).


Note You need to log in before you can comment on or make changes to this bug.