Bug 725272 - "Performing unsafe table load" error during snapshot creation
"Performing unsafe table load" error during snapshot creation
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Alasdair Kergon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-24 18:43 EDT by Olivier Fabre
Modified: 2012-02-02 13:02 EST (History)
13 users (show)

See Also:
Fixed In Version: lvm2-2.02.87-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-02 06:36:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Olivier Fabre 2011-07-24 18:43:29 EDT
Description of problem:
During the creation of an LVM snapshot, the following message is printed:
  Internal error: Performing unsafe table load while 2 device(s) are known to be suspended:  (254:4) 

Version-Release number of selected component (if applicable):
lvm2 2.02.86

How reproducible:
Always. Happens with both my ArchRoot and ArchRoot64 logical volumes (see below.)

Steps to Reproduce:
sudo lvcreate --permission r --size 1G --snapshot --name lvm_backup_snapshot /dev/VGSSD1/ArchRoot
  
Actual results:
This error message is printed:
  Internal error: Performing unsafe table load while 2 device(s) are known to be suspended:  (254:4) 
  Logical volume "lvm_backup_snapshot" created

No other noticeable problem.

Expected results:


Additional info:
pvdisplay:
  --- Physical volume ---
  PV Name               /dev/sdd8
  VG Name               volumegroup1
  PV Size               10.72 GiB / not usable 3.00 MiB
  Allocatable           yes (but full)
  PE Size               4.00 MiB
  Total PE              2744
  Free PE               0
  Allocated PE          2744
  PV UUID               I9ouYV-HoMc-JaYG-Lkb1-dHMc-LQIq-0FBfqS
   
  --- Physical volume ---
  PV Name               /dev/sda2
  VG Name               VGSSD1
  PV Size               46.88 GiB / not usable 4.00 MiB
  Allocatable           yes 
  PE Size               4.00 MiB
  Total PE              11999
  Free PE               4319
  Allocated PE          7680
  PV UUID               j3ub0s-Aigl-cMZX-rYPt-Ru3Z-0bl5-00PVKL
   
lvdisplay:
  --- Logical volume ---
  LV Name                /dev/volumegroup1/archroot
  VG Name                volumegroup1
  LV UUID                0FedgO-iFgz-jW1c-liDu-ZV1h-Ty0O-DBEZiQ
  LV Write Access        read/write
  LV Status              NOT available
  LV Size                10.72 GiB
  Current LE             2744
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
   
  --- Logical volume ---
  LV Name                /dev/VGSSD1/ArchRoot
  VG Name                VGSSD1
  LV UUID                gf2xrp-PXI1-hNc8-KS2U-rg7I-dHRQ-U7v83n
  LV Write Access        read/write
  LV Status              available
  # open                 1
  LV Size                15.00 GiB
  Current LE             3840
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           254:0
   
  --- Logical volume ---
  LV Name                /dev/VGSSD1/ArchRoot64
  VG Name                VGSSD1
  LV UUID                AGOlPg-pB9n-I5AK-7O9d-0uOd-l9yI-tueuIN
  LV Write Access        read/write
  LV Status              available
  # open                 1
  LV Size                15.00 GiB
  Current LE             3840
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           254:1
   
/dev/sdd is an USB disk.
/dev/sda is an SSD.

Arch Linux, kernel 2.6.39.3.
Comment 1 Olivier Fabre 2011-07-24 19:00:25 EDT
Something that may or may not be related, I see this in my dmesg:

[127321.472643] dmeventd (10022): /proc/10022/oom_adj is deprecated, please use /proc/10022/oom_score_adj instead.
[127321.565209] EXT4-fs (dm-2): write access unavailable, skipping orphan cleanup
[127321.565211] EXT4-fs (dm-2): recovery complete
[127321.565215] EXT4-fs (dm-2): mounted filesystem with ordered data mode. Opts: (null)
[127381.802423] EXT4-fs warning (device dm-0): release_blocks_on_commit:2679: discard not supported, disabling
[128438.838490] EXT4-fs warning (device dm-1): release_blocks_on_commit:2679: discard not supported, disabling
[128438.866990] EXT4-fs (dm-2): write access unavailable, skipping orphan cleanup
[128438.866992] EXT4-fs (dm-2): recovery complete
[128438.866996] EXT4-fs (dm-2): mounted filesystem with ordered data mode. Opts: (null)

I don't know when it happened exactly, but nothing more is added to dmesg when I perform the lvcreate command mentionned in the bug report (or the subsequent lvremove.)
I have no "dm-2" in /dev.

My fstab contains:
/dev/VGSSD1/ArchRoot64  /  ext4  noatime,discard,commit=60,errors=remount-ro        0 1
/dev/VGSSD1/ArchRoot    /mnt/arch32  ext4  noatime,discard,commit=60,errors=remount-ro        0 1

and "mount" says:
/dev/VGSSD1/ArchRoot64 on / type ext4 (rw,noatime,errors=remount-ro,user_xattr,acl,commit=60,barrier=1,data=ordered,discard)
/dev/mapper/VGSSD1-ArchRoot on /mnt/arch32 type ext4 (rw,noatime,discard,commit=60,errors=remount-ro)
Comment 2 Alasdair Kergon 2011-07-24 19:07:24 EDT
Amazing.  Reproduced...
Comment 4 Olivier Fabre 2011-07-24 21:50:01 EDT
This patch does remove the error message.

About my previous comment about not having any dm-2, I was wrong of course: there is dm-2 in /dev when the snapshot is created:
$ l /dev/mapper/
total 0
lrwxrwxrwx 1 root       7 Jul 25 03:27 VGSSD1-ArchRoot -> ../dm-0
lrwxrwxrwx 1 root       7 Jul 25 03:27 VGSSD1-ArchRoot-real -> ../dm-3
lrwxrwxrwx 1 root       7 Jul 25 03:19 VGSSD1-ArchRoot64 -> ../dm-1
lrwxrwxrwx 1 root       7 Jul 25 03:27 VGSSD1-lvm_backup_snapshot -> ../dm-2
lrwxrwxrwx 1 root       7 Jul 25 03:27 VGSSD1-lvm_backup_snapshot-cow -> ../dm-4

I guess that explains the "write access unavailable" messages by ext4, since dm-2 is a read-only snapshot.

Still slightly worried about the "discard not supported, disabling" message on dm-0... But that's unrelated to this bug I suppose. (I think it happens the first time the snapshot is created.)
Comment 5 Mike Snitzer 2011-07-24 23:19:07 EDT
(In reply to comment #4)

> Still slightly worried about the "discard not supported, disabling" message on
> dm-0... But that's unrelated to this bug I suppose. (I think it happens the
> first time the snapshot is created.)

This is due to the fact that the snapshot-origin target doesn't support discards.  And ext4 will disable discards as soon as a discard request fails.

Please see:
http://www.redhat.com/archives/dm-devel/2011-April/msg00147.html

AFAIK that ext4 commit still hasn't been reverted or the relevant coded tweaked to simply warn without disabling discard.
Comment 6 Eric Smith 2011-12-22 20:12:18 EST
Got the same error creating a snapshot with F16, lvm2-2.02.86-5.fc16.x86_64.
Comment 7 Eric Smith 2011-12-22 20:14:42 EST
To clarify, the error I got is "Internal error: Performing unsafe table load while 2 device(s) are known to be suspended:  (253:7)".  I do have a "write access unavailable" message in /var/log/messages, which may or may not be related.  I don't see any messages about "discard not supported".
Comment 8 Eric Smith 2012-02-02 11:06:30 EST
It would be really nice if instead of just changed to "closed rawhide", there was a brief explanation of what has changed that has fixed it.  That would make it easier for bug reporters to make sure that they get the appropriate package and confirm that it is fixed.
Comment 9 Peter Rajnoha 2012-02-02 13:02:56 EST
(In reply to comment #8)
> It would be really nice if instead of just changed to "closed rawhide", there
> was a brief explanation of what has changed that has fixed it.  That would make
> it easier for bug reporters to make sure that they get the appropriate package
> and confirm that it is fixed.

The warning message "Performing unsafe table load" is not (incorrectly) issued anymore when creating a read-only snapshot (comment #3 referencing the fix and comment #4 confirming this the fix that the reporter expects). The package this was fixed in is lvm2-2.02.87-1.fc17.

Note You need to log in before you can comment on or make changes to this bug.