Bug 725273 - Alert Definition UI does not display in recent builds of master.
Alert Definition UI does not display in recent builds of master.
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Alerts (Show other bugs)
unspecified
Unspecified Unspecified
urgent Severity urgent (vote)
: ---
: ---
Assigned To: Simeon Pinder
Mike Foley
:
Depends On:
Blocks: jon3 rhq41beta
  Show dependency treegraph
 
Reported: 2011-07-24 18:51 EDT by Simeon Pinder
Modified: 2012-02-07 14:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simeon Pinder 2011-07-24 18:51:09 EDT
Description of problem: Unable to define new Alert definitions with the SmartGwt UI. Navigating to the Alert Definitions page displays error messages and no content displayed. See below for error message details.

Version-Release number of selected component (if applicable):

How reproducible:
Always

Steps to Reproduce:
1. Log into UI and navigate to any resource. Click Alerts>Definitions tab.
2. Observe error messages in MessageCenter.
3.
  
Actual results:
Red error message shown with details in MessageCenter.

Failed to draw Table [<>::class org.rhq.enterprise.gui.coregui.client.alert.definitions.ResourceAlertDefinitionsView, ID:isc_ResourceAlertDefinitionsView_0].
Severity :	
Error

Time :	
Sunday, July 24, 2011 6:40:20 PM Etc/GMT+4
Detail :	
com.google.gwt.core.client.JavaScriptException:(TypeError): Cannot call method 'getOrCreateJsObj__Lcom_google_gwt_core_client_JavaScriptObject_2' of null arguments: getOrCreateJsObj__Lcom_google_gwt_core_client_JavaScriptObject_2, type: non_object_property_call stack: TypeError: Cannot call method 'getOrCreateJsObj__Lcom_google_gwt_core_client_JavaScriptObject_2' of null at com_smartgwt_client_data_ResultSet_$lengthIsKnown__Lcom_smartgwt_client_data_ResultSet_2Ljava_lang_Boolean_2 (http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D6C1AD1401A994635A12B9280B26AAF4.cache.html:22111:26) at org_rhq_enterprise_gui_coregui_client_components_table_Table_$refreshRowCount__Lorg_rhq_enterprise_gui_coregui_client_components_table_Table_2V (http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D6C1AD1401A994635A12B9280B26AAF4.cache.html:99067:221) at org_rhq_enterprise_gui_coregui_client_components_table_Table_$onDraw__Lorg_rhq_enterprise_gui_coregui_client_components_table_Table_2V (http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D6C1AD1401A994635A12B9280B26AAF4.cache.html:98986:5) at Object.org_rhq_enterprise_gui_coregui_client_components_table_Table_onDraw__V [as onDraw__V] (http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D6C1AD1401A994635A12B9280B26AAF4.cache.html:99347:3) at Object.com_smartgwt_client_widgets_BaseWidget_rendered__V [as private$com_smartgwt_client_widgets_BaseWidget$rendered__V] (http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D6C1AD1401A994635A12B9280B26AAF4.cache.html:27186:8) at Object.draw (http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D6C1AD1401A994635A12B9280B26AAF4.cache.html:27093:10) at Object.isc_Layout_layoutChildren [as layoutChildren] (http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Foundation.js:439:165) at Object.isc_Layout_reflowNow [as reflowNow] (http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Foundation.js:457:92) at http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Foundation.js:456:218 at Object.isc_c_EventHandler_runTeas [as runTeas] (http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Core.js:1558:83)
--- STACK TRACE FOLLOWS ---
(TypeError): Cannot call method 'getOrCreateJsObj__Lcom_google_gwt_core_client_JavaScriptObject_2' of null arguments: getOrCreateJsObj__Lcom_google_gwt_core_client_JavaScriptObject_2, type: non_object_property_call stack: TypeError: Cannot call method 'getOrCreateJsObj__Lcom_google_gwt_core_client_JavaScriptObject_2' of null at com_smartgwt_client_data_ResultSet_$lengthIsKnown__Lcom_smartgwt_client_data_ResultSet_2Ljava_lang_Boolean_2 (http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D6C1AD1401A994635A12B9280B26AAF4.cache.html:22111:26) at org_rhq_enterprise_gui_coregui_client_components_table_Table_$refreshRowCount__Lorg_rhq_enterprise_gui_coregui_client_components_table_Table_2V (http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D6C1AD1401A994635A12B9280B26AAF4.cache.html:99067:221) at org_rhq_enterprise_gui_coregui_client_components_table_Table_$onDraw__Lorg_rhq_enterprise_gui_coregui_client_components_table_Table_2V (http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D6C1AD1401A994635A12B9280B26AAF4.cache.html:98986:5) at Object.org_rhq_enterprise_gui_coregui_client_components_table_Table_onDraw__V [as onDraw__V] (http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D6C1AD1401A994635A12B9280B26AAF4.cache.html:99347:3) at Object.com_smartgwt_client_widgets_BaseWidget_rendered__V [as private$com_smartgwt_client_widgets_BaseWidget$rendered__V] (http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D6C1AD1401A994635A12B9280B26AAF4.cache.html:27186:8) at Object.draw (http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/D6C1AD1401A994635A12B9280B26AAF4.cache.html:27093:10) at Object.isc_Layout_layoutChildren [as layoutChildren] (http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Foundation.js:439:165) at Object.isc_Layout_reflowNow [as reflowNow] (http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Foundation.js:457:92) at http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Foundation.js:456:218 at Object.isc_c_EventHandler_runTeas [as runTeas] (http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Core.js:1558:83)
    at Unknown.com_smartgwt_client_data_ResultSet_$lengthIsKnown__Lcom_smartgwt_client_data_ResultSet_2Ljava_lang_Boolean_2(Unknown source:0)
    at Unknown.org_rhq_enterprise_gui_coregui_client_components_table_Table_$refreshRowCount__Lorg_rhq_enterprise_gui_coregui_client_components_table_Table_2V(Unknown source:0)
    at Unknown.org_rhq_enterprise_gui_coregui_client_components_table_Table_$onDraw__Lorg_rhq_enterprise_gui_coregui_client_components_table_Table_2V(Unknown source:0)
    at Unknown.org_rhq_enterprise_gui_coregui_client_components_table_Table_onDraw__V(Unknown source:0)
    at Unknown.com_smartgwt_client_widgets_BaseWidget_rendered__V(Unknown source:0)
    at Unknown.draw(Unknown source:0)
    at Unknown.isc_Layout_layoutChildren(Unknown source:0)
    at Unknown.isc_Layout_reflowNow(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
    at Unknown.isc_c_EventHandler_runTeas(Unknown source:0)

Expected results:
Display alert definition UI.

Additional info:
Comment 1 Simeon Pinder 2011-07-25 10:28:32 EDT
Some more info:

- Most recent pull for master was over the weekend. 

- Portal.war ui for alert definition still works as a temporary work around. 

- Making this issue urgent as is a regression in coregui.
Comment 2 Charles Crouch 2011-07-25 10:55:01 EDT
(9:43:08 AM) mazz: re: the alerts UI
(9:43:16 AM) mazz: that should be fixed. we merged into maseter last week
(9:43:22 AM) mazz: and I tried creating alet defs and it worked for me
(9:43:25 AM) mazz: is that still broken in masteR?
segfault sgilda shaines shaun spinder stefan_n sweaver 
(9:43:58 AM) ccrouch: spinder: ^ ?
(9:46:05 AM) mazz: see my 10:40-ish posts in #rhq last Friday on this
(9:46:08 AM) mazz: (10:41:56 AM) mazz: BTW: the fact that jsanda merged the drift branch into master means (I think) those problems people had with adding alerts is fixed
(9:46:08 AM) mazz: (10:42:06 AM) mazz: I suspect it had to do with changes that I fixed in the Table class.
(9:46:08 AM) mazz: (10:42:30 AM) mazz: side note: we need to make a rule - ANY one changing the GWT Table or TableSection needs to get it peer reviewed before commit :)
(9:50:29 AM) spinder: mazz: I was hoping so but I pulled on Sunday, did a full build with clean and I staill saw the problem.  
(9:51:05 AM) spinder: can anyone else who has built with master recently confirm fix or bug?
(9:51:17 AM) mazz: ok, so here's what I see
(9:51:18 AM) mazz: Unknown.com_smartgwt_client_data_ResultSet_$lengthIsKnown__Lcom_smartgwt_client_data_ResultSet_2Ljava_lang_Boolean_2(Unknown source:0)     at Unknown.org_rhq_enterprise_gui_coregui_client_components_table_Table_$refreshRowCount__Lorg_rhq_enterprise_gui_coregui_client_components_table_Table_2V(Unknown source:0) 
(9:51:29 AM) mazz: this is the change that ips put in that I was talking about in Table
(9:51:32 AM) mazz: I thought I fixed this
(9:51:40 AM) mazz: please make sure you REALLY did a full clean rebuild
(9:51:57 AM) mazz: and this is why we need to have things tested and peer reviewed if things change in Table or TableSection.
(9:52:17 AM) mazz: because ANY kind of odd problem will affect many many UI views (all those that have table views in them)
(9:52:27 AM) spinder: mazz: agreed. I'm currently walking through alert code.  I'll rebuild in a bit... but that takes like 30 mins. 
(9:53:16 AM) spinder: mazz: +1 to peer reviews of Tables, View etc for coregui. We reuse those parent classes quite often everywhere.
Comment 3 Charles Crouch 2011-07-25 12:41:19 EDT
Pushing to ON_QA to see if they can quickly check this.

Obviously if its still bust, please set on ON_DEV and assign to mazz
Comment 4 Mike Foley 2011-07-25 14:10:59 EDT
verified RHQ 4.1 master build 7/25 build, as follows:
1) alert definition ... seems fine, no UI errors
2) additionally verified alerts firing correctly by defining an alert on the RHQ agent on availability change, and stopping/starting the RHQ agent.  observed 2 alerts fired.
Comment 5 Mike Foley 2011-07-25 14:16:52 EDT
Specifically  defining the alert definitions I used during the verification:

1) RHQ Agent, availability change, 2 conditions ... goes down, comes up.  I restarted the agent and saw the agent fire 2 times.

2) Platform, Metric value threshold

total memory > 0
total swap > 0
Comment 6 Simeon Pinder 2011-07-26 12:19:37 EDT
In looking back through the mvn build for my test run I did not include 'clean' as I had initially thought.
Comment 7 Mike Foley 2012-02-07 14:30:03 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE
Comment 8 Mike Foley 2012-02-07 14:30:29 EST
marking VERIFIED BZs to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.