Bug 725339 - net-snmp UCD-SNMP-MIB doesn't report Inodes any more
Summary: net-snmp UCD-SNMP-MIB doesn't report Inodes any more
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: net-snmp
Version: 5.7
Hardware: All
OS: Linux
urgent
high
Target Milestone: rc
: ---
Assignee: Jan Safranek
QA Contact: Dalibor Pospíšil
URL:
Whiteboard:
Depends On:
Blocks: 732943
TreeView+ depends on / blocked
 
Reported: 2011-07-25 08:48 UTC by Mario Heininger
Modified: 2018-11-14 11:24 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In the previous net-snmp update, implementation of the UCD-SNMP-MIB::dskTable table was rewritten and reporting of the UCD-SNMP-MIB::dskPercentNode column was accidentally removed from the snmpd daemon. With this update, the object identifier for UCD-SNMP-MIB::dskPercentNode has been restored and it now properly reports percentages of used inodes on storage devices, thus fixing this bug.
Clone Of:
Environment:
Last Closed: 2012-02-21 06:32:06 UTC


Attachments (Terms of Use)
a fix (1.58 KB, patch)
2011-07-25 13:50 UTC, Jan Safranek
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0165 normal SHIPPED_LIVE net-snmp bug fix update 2012-02-20 15:06:44 UTC

Description Mario Heininger 2011-07-25 08:48:12 UTC
Description of problem:

The UCD-SNMP-MIB Table has Fields for DskPercentNode (Used Inodes in Percent), after Upgrade to net-snmp-5.3.2.2-9.el5_5.1 the Field isn't reported any more.


Version-Release number of selected component (if applicable):
net-snmp-5.3.2.2-9.el5_5.1

How reproducible:
Install net-snmp from RHEL5.6 Tree , DskPercentNode is reported, update to RHEL5.7 Tree, DskPercentNode list only -1 on all Devices.



Steps to Reproduce:
1. Install RHEL5.6 NET-SNMP

2. snmpwalk the ucd-snmp-mib
# snmpwalk -v2c -cXXXXXX 127.0.0.1 .1.3.6.1.4.1.2021.9 | grep "dskPercentNode"
UCD-SNMP-MIB::dskPercentNode.1 = INTEGER: 13
UCD-SNMP-MIB::dskPercentNode.2 = INTEGER: 2
UCD-SNMP-MIB::dskPercentNode.3 = INTEGER: 27


3. Upgrade to RHEL5.7 NET-SNMP

4. snmpwalk again the ucd-snmp-mib
# snmpwalk -v2c -cXXXXXX 127.0.0.1 .1.3.6.1.4.1.2021.9 | grep "dskPercentNode"
UCD-SNMP-MIB::dskPercentNode.1 = INTEGER: -1
UCD-SNMP-MIB::dskPercentNode.2 = INTEGER: -1
UCD-SNMP-MIB::dskPercentNode.3 = INTEGER: -1

Comment 1 Mario Heininger 2011-07-25 09:51:59 UTC
After Codeview i found that the net-snmp-5.3.2.2-dskTable-64.patch removes the "inode" Sections in the Sourcecode.

Comment 2 Jan Safranek 2011-07-25 13:50:55 UTC
Created attachment 515055 [details]
a fix

I forgot to rename some macro names when backporting newer dskTable from upstream.

Comment 4 Mario Heininger 2011-07-26 06:38:42 UTC
Hello Jan,

thank you, i have tested the patch with an recompile of the Red Hat Package. The Patch works, inode in usd-snmp-mib works.

Bye Mario

Comment 10 Tomas Capek 2011-08-25 14:03:41 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
In the previous net-snmp update, implementation of the UCD-SNMP-MIB::dskTable table was rewritten and reporting of the UCD-SNMP-MIB::dskPercentNode column was accidentally removed from the snmpd daemon. With this update, the object identifier for UCD-SNMP-MIB::dskPercentNode has been restored and it now properly reports percentages of used inodes on storage devices, thus fixing this bug.

Comment 13 errata-xmlrpc 2012-02-21 06:32:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0165.html


Note You need to log in before you can comment on or make changes to this bug.