Bug 725384 (CVE-2011-2719, PMASA-2011-12) - CVE-2011-2719 phpMyAdmin: v3.3.10.3, v3.4.3.2: Possible session manipulation in Swekey extention authentication (PMASA-2011-12)
Summary: CVE-2011-2719 phpMyAdmin: v3.3.10.3, v3.4.3.2: Possible session manipulation ...
Status: CLOSED ERRATA
Alias: CVE-2011-2719, PMASA-2011-12
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
(Show other bugs)
Version: unspecified
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: public=20110723,reported=20110724,sou...
Keywords: Security
Depends On: 725385 725386
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-25 11:00 UTC by Jan Lieskovsky
Modified: 2015-07-31 06:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-10 08:20:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jan Lieskovsky 2011-07-25 11:00:22 UTC
A session values manipulation flaw was found in the way phpMyAdmin, the MySQL over WWW administration tool, performed sanitization of the user-provided query string, when the Swekey extension based authentication method was enabled. A remote attacker could use this flaw to manipulate the PHP session superglobal variable via specially-crafted query string provided to the Swekey authentication module.

References:
[1] http://www.phpmyadmin.net/home_page/security/PMASA-2011-12.php
[2] http://www.phpmyadmin.net/home_page/news.php
[3] http://seclists.org/fulldisclosure/2011/Jul/300

Upstream patches:
[4] http://phpmyadmin.git.sourceforge.net/git/gitweb.cgi?p=phpmyadmin/phpmyadmin;a=commitdiff;h=e7bb42c002885c2aca7aba4d431b8c63ae4de9b7
[5] http://phpmyadmin.git.sourceforge.net/git/gitweb.cgi?p=phpmyadmin/phpmyadmin;a=commitdiff;h=571cdc6ff4bf375871b594f4e06f8ad3159d1754

Patches against v3.3 branch:
[6] http://phpmyadmin.git.sourceforge.net/git/gitweb.cgi?p=phpmyadmin/phpmyadmin;a=commitdiff;h=f6f6ee3f1171addb166fa18e75a0b56599bf374c
[7] http://phpmyadmin.git.sourceforge.net/git/gitweb.cgi?p=phpmyadmin/phpmyadmin;a=commitdiff;h=630b8260be45eb9b211f5d7628dbb9e5c1b05bc6

Affected Versions:
The 3.4.3.1 and earlier versions are affected.
Branch 2.11.x is not affected by this.

Comment 1 Jan Lieskovsky 2011-07-25 11:01:26 UTC
This issue affects the versions of the phpMyAdmin package, as shipped with
Fedora release of 14 and 15.

Please schedule an update.

--

This issue affects the version of the phpMyAdmin package, as present within
EPEL-6 repository.

Please schedule an update.

--

This issue did NOT affect the versions of the phpMyAdmin package, as present
within EPEL-4 and EPEL-5 repositories.

Comment 2 Jan Lieskovsky 2011-07-25 11:05:32 UTC
Created phpMyAdmin tracking bugs for this issue

Affects: fedora-all [bug 725385]
Affects: epel-6 [bug 725386]

Comment 3 Jan Lieskovsky 2011-07-25 11:15:50 UTC
CVE Request:
[8] http://www.openwall.com/lists/oss-security/2011/07/25/4

Comment 4 Vincent Danen 2011-07-26 20:03:13 UTC
This has been assigned the name CVE-2011-2719:

http://www.openwall.com/lists/oss-security/2011/07/26/10


Note You need to log in before you can comment on or make changes to this bug.