Bug 72540 - Unable to edit panel icons as user or root
Unable to edit panel icons as user or root
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-panel (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-08-24 20:00 EDT by Chris Kloiber
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-30 18:48:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix hoarding default launchers (882 bytes, patch)
2002-08-25 05:52 EDT, George Lebl
no flags Details | Diff

  None (edit)
Description Chris Kloiber 2002-08-24 20:00:01 EDT
Description of Problem:

(Clean install of re-0824.0 tree)

I was attempting to add the option --no-splash to the Command: field of the
panel launcher for Evolution. If you type any character into the field (don't
even have to submit the change) you get this error messge:

"Cannot save launcher to disk, the following error occured:

Error writing file 'applications:///Internet/redhat-email.desktop':
Read-only file system"

You get the same error attempting to change the Icon, or trying to make any
other changes to the Launcher. Same error occurs when logged in as root.
Comment 1 Chris Kloiber 2002-08-24 20:08:36 EDT
Changed Summary- I can't spell today.
Comment 2 Havoc Pennington 2002-08-24 22:27:49 EDT
So this is because I disabled menu editing - apparently launcher editing is 
the same mechanism.

We can't enable menu editing as it doesn't work. How can we get launcher editing
to work? Anyone have ideas?
Comment 3 George Lebl 2002-08-25 05:39:29 EDT
Something is wrong, launchers should be hoarded (panel should have private
copies) and edit those.  This seems more like trying to edit the menus to me. 
Where is the launcher?  On the panel or in the menu?  If it is on the panel how
did you get it onto the panel?  Or was it in the default config.
Comment 4 George Lebl 2002-08-25 05:51:48 EDT
Just fixed this in CVS on all branches.  Must have been one of the default
launchers.  Attaching a patch to fix the problem.  Basically if we load
something from gconf we check if it's in the private path, and if it is, then we
hoard it (make a private copy)
Comment 5 George Lebl 2002-08-25 05:52:47 EDT
Created attachment 72825 [details]
patch to fix hoarding default launchers
Comment 6 Havoc Pennington 2002-08-25 11:57:23 EDT
george rules!
Comment 7 Havoc Pennington 2002-08-25 15:07:04 EDT
2.0.6-6 should have this fix.
Comment 8 Geert Noel 2002-08-30 11:12:47 EDT
The latest gnome summary mentions that menu editing has been fixed in the Gnome
CVS. Any chance this fix gets included for this release? It might save some
support calls from people who are trying to add an item to the menu ;)
Comment 9 Havoc Pennington 2002-08-30 13:01:48 EDT
The changes to make menu editing work are too large (many thousand lines of code), 
and we don't have enough time to test them.
Comment 10 Chris Kloiber 2002-08-30 18:48:47 EDT
While I can't add or edit properties of items in the menus, (that's expected
ATM) I can now edit the icon properties of items on the gnome panel, and can use
Add To Panel/Remove From Panel. So I consider this bug fixed. Thanks.
Comment 11 Jay Turner 2002-08-30 22:17:06 EDT
Closing out based on feedback from user.

Note You need to log in before you can comment on or make changes to this bug.