Bug 72546 - reboot hangs
reboot hangs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-25 00:47 EDT by Michal Jaegermann
Modified: 2016-11-24 10:17 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-22 01:01:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Serial console capture of "tasks" and "processor" after reboot stopped (4.55 KB, text/plain)
2002-08-26 18:22 EDT, Michal Jaegermann
no flags Details
Output of dmesg for a machine in question (7.03 KB, text/plain)
2002-08-26 18:23 EDT, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2002-08-25 00:47:36 EDT
Description of Problem:

An attempt to reboot by picking up "Reboot" on gdm screen ended up with the
following messages:

Unmounting file systems: umount2: Device or resources busy
umount: /dev/sdb2: not mounted
umount: /usr: Illegal seek

INIT: no more processes left in this runlevel

... and in this moment came "a power switch time".  I waited around five
minutes waiting if something will happen.  Nada.

A test system was using /dev/sdb1 as / and /dev/sdb2 mounted on /usr.
No file systems were mounted from other disks although swap was using these.
Incidents of that sort do not happen where running RH 7.3 (and earlier
installations) on the same machine.
Comment 1 Havoc Pennington 2002-08-25 00:53:04 EDT
have you tried more than once with gdm with the same result? have you tried with
'reboot' from console?
Comment 2 Michal Jaegermann 2002-08-25 01:10:50 EDT
Reboot from a console did work.  Not on that occasion, clearly enough, and
I forgot to turn on "magic sysrq" immediately after an installation so,
unfortunately, I could not even try to check what was happening there.

I will do more reboots from gdm (later, this is the same system as my
"normal" one only a different disk) but this may depend what was happening
before that on a desktop.  Sigh!
Comment 3 Michal Jaegermann 2002-08-25 17:14:11 EDT
You are actually right.  This is not gdm problem.  I can stuck my box
on a reboot also using a console regardless if I am using 2.4.18-11 or
2.4.18-12.4.  SysRq seems to indicate that kjournald blocks in
'interruptible_sleep_on'.  Unfortunately nothing in log files as this
happens so late that no user-space processes are around (this includes
syslogd).

If really required I guess that I may rig some kind of a serial console
but that only later.

Should I resubmit that for another component (kernel?) or this can be changed
on bugzilla?
Comment 4 Havoc Pennington 2002-08-25 17:39:21 EDT
Moving, thanks.
Comment 5 Stephen Tweedie 2002-08-26 10:35:09 EDT
"interruptible_sleep_on" (ie. "S" state) is the normal state of a sleeping
kjournald process.  It would be in "D" state if it were blocked on anything; the
"S" state is normal for a kjournal which is idle. So, whatever the problem is
here, it doesn't look like ext3 is the root cause.

The serial console would probably be helpful here.
Comment 6 Michal Jaegermann 2002-08-26 18:19:38 EDT
Ok, attached are serial console captures of "sysrq-T" and "sysrq-P".
Also what was stored in /var/log/dmesg before we hanged on reboot. :-)
Comment 7 Michal Jaegermann 2002-08-26 18:22:16 EDT
Created attachment 73228 [details]
Serial console capture of "tasks" and "processor" after reboot stopped
Comment 8 Michal Jaegermann 2002-08-26 18:23:47 EDT
Created attachment 73229 [details]
Output of dmesg for a machine in question
Comment 9 Bill Nottingham 2002-08-27 20:47:07 EDT
The illegal seek hang on reboot is a glibc issue.
Comment 10 Moritz Barsnick 2002-09-03 06:17:04 EDT
Seeing as there are no remarks to which versions of glibc are
the culprits, here my experience (confirmed by update and then
going back to old version):

I had exactly the same umount2 phenomenon.

glibc-2.2.90-23 works (no problem)
glibc-2.2.90-26 does not work (umount/umount2 complains, leads to journal
                recovery at next mount/boot)

Does that close you in on the problem?  :-)

Greetings,
Moritz
Comment 11 Gene Czarcinski 2002-09-03 06:21:47 EDT
This appears to be fixed in 2.2.92-2 which is available via rhn/up2date
Comment 12 Ulrich Drepper 2003-04-22 01:01:28 EDT
Apparently fixed now.  Closing the bug.  If there is a problem reopen.

Note You need to log in before you can comment on or make changes to this bug.