Bug 725517 - Constant wifi disconnects caused by wpa_supplicant crash due to incorrect dbus use
Constant wifi disconnects caused by wpa_supplicant crash due to incorrect dbu...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
15
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-25 14:32 EDT by Adam Williamson
Modified: 2011-08-22 10:55 EDT (History)
1 user (show)

See Also:
Fixed In Version: wpa_supplicant-0.7.3-9.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-02 22:32:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
abrt crash trace (33.87 KB, text/x-log)
2011-07-25 14:32 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2011-07-25 14:32:27 EDT
Created attachment 515123 [details]
abrt crash trace

I'm in a Starbucks by the Lloyd Center in Portland using the free wifi connection. It's constantly disconnecting and reconnecting. This seems to be caused by a crash in wpa-supplicant, which in turn is I think due to NetworkManager using its dbus interface incorrectly. I'll attach the abrt trace. I've downgraded NetworkManager to test if this is a bug introduced in the recent update - https://admin.fedoraproject.org/updates/NetworkManager-0.8.9997-6.git20110721.fc15,NetworkManager-openswan-0.8.999-2.git20110721.fc15,NetworkManager-openvpn-0.8.9997-2.git20110721.fc15,NetworkManager-vpnc-0.8.999-3.git20110721.fc15,NetworkManager-pptp-0.8.999-2.git20110721.fc15 . Will report back soon if the downgrade seems to fix the problem.
Comment 1 Adam Williamson 2011-07-25 14:36:00 EDT
I've been running with the downgraded version for several minutes now, long enough that I'd have expected the crash to happen by now, so I suspect this is a regression in the update.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Dan Williams 2011-07-25 14:57:27 EDT
Hmm, can you grab a backtrace from the supplicant for me by 'gdb attach'-ing to it or something so I can see what's going on?  I don't recall anything specific that got changed with talking to the supplicant, but the backtrace might shed more light on the issue.  The supplicant thing *might* be a dupe of bug 678625 which upstream half-fixed and I pulled that fix into the supplicant package a while ago.  Perhaps this time we have to fix it for real.
Comment 3 Dan Williams 2011-07-25 15:01:26 EDT
Haha, nevermind; you did attach the backtrace.  My bad. So this does look like bug 678625 is rearing its head again.  This bug is trigged by some odd AP beacon frames that don't parse, which should really be fixed in the supplicant, but obviously it shouldn't crash here either due to supplicant mis-use of D-Bus.
Comment 4 Dan Williams 2011-07-25 15:03:23 EDT
I don't have any idea why this is apparently triggered by this NM update, but it's clearly not actually an NM bug, but a supplicant issue.  So moving to supplicant.
Comment 5 Dan Williams 2011-07-25 15:04:56 EDT
Also, if you happen to be back at that starbucks, could you:

sudo iw dev wlan0 scan

and paste all that into the bug so we can take a look at the beacon that's killing the supplicant.
Comment 6 Adam Williamson 2011-07-25 15:14:47 EDT
Hah, I was just writing a comment that it seemed to be definitely caused by the NM update as I'd been connected for an hour or so with no trouble, when the bug happened! So it does seem to happen with the older NM too, though the frequency of the bug occurring is odd. Maybe it relates to the time or something. Here's the iw output - the AP in question is the first one, attwifi, but I left the others in in case they're relevant:

BSS 00:22:55:c3:96:81 (on wlan0) -- associated
	TSF: 6419249971506 usec (74d, 07:07:29)
	freq: 2437
	beacon interval: 100
	capability: ESS ShortSlotTime (0x0401)
	signal: -53.00 dBm
	last seen: 110 ms ago
	Information elements from Probe Response frame:
	SSID: attwifi
	Supported rates: 1.0 2.0* 5.5 6.0 9.0 11.0 12.0 18.0 
	DS Parameter set: channel 6
	ERP: Barker_Preamble_Mode
	Extended supported rates: 24.0 36.0 48.0 54.0 
	WMM:	 * Parameter version 1
		 * BE: CW 15-1023, AIFSN 3
		 * BK: CW 15-1023, AIFSN 7
		 * VI: CW 7-15, AIFSN 2, TXOP 3008 usec
		 * VO: CW 3-7, AIFSN 2, TXOP 1504 usec
BSS 00:22:55:c3:96:82 (on wlan0)
	TSF: 6419245363506 usec (74d, 07:07:25)
	freq: 2437
	beacon interval: 100
	capability: ESS ShortSlotTime (0x0401)
	signal: -61.00 dBm
	last seen: 4650 ms ago
	SSID: \x00
	Supported rates: 1.0 2.0* 5.5 6.0 9.0 11.0 12.0 18.0 
	DS Parameter set: channel 6
	TIM: DTIM Count 1 DTIM Period 2 Bitmap Control 0x0 Bitmap[0] 0x0
	ERP: Barker_Preamble_Mode
	Extended supported rates: 24.0 36.0 48.0 54.0 
	WMM:	 * Parameter version 1
		 * BE: CW 15-1023, AIFSN 3
		 * BK: CW 15-1023, AIFSN 7
		 * VI: CW 7-15, AIFSN 2, TXOP 3008 usec
		 * VO: CW 3-7, AIFSN 2, TXOP 1504 usec
BSS 00:22:55:c3:96:80 (on wlan0)
	TSF: 6419245465906 usec (74d, 07:07:25)
	freq: 2437
	beacon interval: 100
	capability: ESS ShortSlotTime (0x0401)
	signal: -55.00 dBm
	last seen: 4684 ms ago
	Information elements from Probe Response frame:
	SSID: QwestWiFi
	Supported rates: 1.0 2.0* 5.5 6.0 9.0 11.0 12.0 18.0 
	DS Parameter set: channel 6
	ERP: Barker_Preamble_Mode
	Extended supported rates: 24.0 36.0 48.0 54.0 
	WMM:	 * Parameter version 1
		 * BE: CW 15-1023, AIFSN 3
		 * BK: CW 15-1023, AIFSN 7
		 * VI: CW 7-15, AIFSN 2, TXOP 3008 usec
		 * VO: CW 3-7, AIFSN 2, TXOP 1504 usec
BSS 00:15:6d:64:6c:72 (on wlan0)
	TSF: 13540007005634 usec (156d, 17:06:47)
	freq: 5745
	beacon interval: 100
	capability: ESS Privacy ShortPreamble ShortSlotTime (0x0431)
	signal: -83.00 dBm
	last seen: 819 ms ago
	SSID: lloydnw1
	Supported rates: 6.0* 9.0 12.0 18.0 24.0 36.0 48.0 54.0 
	TIM: DTIM Count 0 DTIM Period 1 Bitmap Control 0x0 Bitmap[0] 0x0
	RSN:	 * Version: 1
		 * Group cipher: CCMP
		 * Pairwise ciphers: CCMP
		 * Authentication suites: PSK
BSS 00:23:68:8e:b5:40 (on wlan0)
	TSF: 1310930331780 usec (15d, 04:08:50)
	freq: 2437
	beacon interval: 100
	capability: ESS Privacy ShortSlotTime (0x0411)
	signal: -84.00 dBm
	last seen: 4673 ms ago
	SSID: 101
	Supported rates: 1.0* 2.0* 5.5* 11.0* 6.0 9.0 12.0 18.0 
	DS Parameter set: channel 6
	TIM: DTIM Count 2 DTIM Period 10 Bitmap Control 0x0 Bitmap[0] 0x0
	Country: US	Environment: Indoor/Outdoor
		Channels [1 - 11] @ 30 dBm
	ERP: Use_Protection Barker_Preamble_Mode
	Extended supported rates: 24.0 36.0 48.0 54.0 
BSS 00:0d:67:14:47:45 (on wlan0)
	TSF: 54474547584 usec (0d, 15:07:54)
	freq: 2437
	beacon interval: 100
	capability: ESS Privacy ShortPreamble SpectrumMgmt ShortSlotTime (0x0531)
	signal: -85.00 dBm
	last seen: 4737 ms ago
	SSID: 
	Supported rates: 1.0* 2.0* 5.5* 11.0* 6.0 9.0 12.0 18.0 
	DS Parameter set: channel 6
	TIM: DTIM Count 0 DTIM Period 3 Bitmap Control 0x0 Bitmap[0] 0x0
	Country: US	Environment: Outdoor only
		Channels [1 - 13] @ 30 dBm
	Power constraint: 0 dB
	ERP: <no flags>
	WPA:	 * Version: 1
		 * Group cipher: CCMP
		 * Pairwise ciphers: CCMP
		 * Authentication suites: PSK
	Extended supported rates: 24.0 36.0 48.0 54.0 
	WMM:	 * Parameter version 1
		 * u-APSD
		 * BE: CW 15-1023, AIFSN 3
		 * BK: CW 15-1023, AIFSN 7
		 * VI: CW 7-15, AIFSN 2, TXOP 3008 usec
		 * VO: acm CW 3-7, AIFSN 2, TXOP 1504 usec



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Adam Williamson 2011-07-25 15:16:15 EDT
Last call for any other info you need from the AP - I'm gonna leave the Starbucks in five minutes or so and I'm not gonna be back in Portland for a year, so if you need anything, now's the time!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Fedora Update System 2011-07-27 11:59:47 EDT
wpa_supplicant-0.7.3-9.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/wpa_supplicant-0.7.3-9.fc15
Comment 9 Fedora Update System 2011-07-27 12:00:53 EDT
wpa_supplicant-0.7.3-9.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/wpa_supplicant-0.7.3-9.fc16
Comment 10 Fedora Update System 2011-07-30 23:31:48 EDT
Package wpa_supplicant-0.7.3-9.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wpa_supplicant-0.7.3-9.fc15'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/wpa_supplicant-0.7.3-9.fc15
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2011-08-02 22:32:38 EDT
wpa_supplicant-0.7.3-9.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2011-08-22 10:55:58 EDT
wpa_supplicant-0.7.3-9.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.