Bug 725569 - gcc-plugin-devel missing requirement on gmp-devel
Summary: gcc-plugin-devel missing requirement on gmp-devel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-25 20:57 UTC by Dave Malcolm
Modified: 2011-08-22 15:27 UTC (History)
1 user (show)

Fixed In Version: gcc-4.6.1-7.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-22 15:27:08 UTC
Type: ---


Attachments (Terms of Use)

Description Dave Malcolm 2011-07-25 20:57:06 UTC
Description of problem:
I tried a scratch build of my gcc-python-plugin in rawhide:
  http://koji.fedoraproject.org/koji/taskinfo?taskID=3228581

It failed with this error:
In file included from /usr/lib/gcc/x86_64-redhat-linux/4.6.1/plugin/include/tree.h:31:0,
                 from gcc-python.h:24,
                 from gcc-python-closure.c:24:
/usr/lib/gcc/x86_64-redhat-linux/4.6.1/plugin/include/double-int.h:24:17: fatal error: gmp.h: No such file or directory

It looks like gmp.h is part of gmp-devel, and that gcc-plugin-devel should have an explicit:

  Requires: gmp-devel

to pull this in (4.6.0 worked OK, fwiw).


Version-Release number of selected component (if applicable):
gcc-4.6.1-3.fc16

How reproducible:
100%

Steps to Reproduce:
1.  Attempt to build a gcc plugin in Koji using just BuildRequires: gcc-plugin-devel
  
Actual results:
Build fails due to missing headers

Expected results:
Build succeeds

Comment 1 Dave Malcolm 2011-07-25 20:57:54 UTC
(In reply to comment #0)
>  (4.6.0 worked OK, fwiw).
[fwiw, I take this back, I'm not sure it did]

Comment 2 Fedora Update System 2011-07-27 17:56:54 UTC
gcc-4.6.1-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gcc-4.6.1-4.fc16

Comment 3 Fedora Update System 2011-08-01 20:15:55 UTC
Package gcc-4.6.1-5.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gcc-4.6.1-5.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/gcc-4.6.1-5.fc16
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2011-08-03 19:14:17 UTC
Package gcc-4.6.1-6.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gcc-4.6.1-6.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/gcc-4.6.1-6.fc16
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2011-08-05 20:07:20 UTC
Package gcc-4.6.1-7.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gcc-4.6.1-7.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/gcc-4.6.1-7.fc16
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2011-08-22 15:26:43 UTC
gcc-4.6.1-7.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.