Bug 72559 - RPM suggestion regarding dependencies
Summary: RPM suggestion regarding dependencies
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-25 12:40 UTC by Yury Sulsky
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-25 12:40:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Yury Sulsky 2002-08-25 12:40:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020615
Debian/1.0.0-3

Description of problem:
Since the developers know where to get the dependent rpms, why not make that a
part of the rpm format? Simply add a list of locations where each dependency can
be downloaded. If this doesn't exist, then users will have to find the
dependencies themselves. Otherwise, you get many of the same benefits of
utilities such as apt, urpmi, and red-carpet without the disadvantages (a
centralized database, and thus not as up to date as developer-maintained
packages). This feature is backward compatible, so there is no harm in adding it.

Comment 1 Jeff Johnson 2002-08-25 13:13:46 UTC
Mostly yes, but not in packages. New packages are
built too frequently for any suggestions contained
in packages to be useful for more than, say, a week.

The trick is to associate the information with, but not
in, a package. See rpmcache(8) for how this will be implemented.


Note You need to log in before you can comment on or make changes to this bug.