Bug 72565 - nVIDIA Driver Module will not install because of gcc mismatch
nVIDIA Driver Module will not install because of gcc mismatch
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gcc3 (Show other bugs)
7.3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-25 12:29 EDT by Florian Rommel
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-25 12:29:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian Rommel 2002-08-25 12:29:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
trying to biuld the kernel source module from nVIDIA's Drivers, will not 
install on  the (null) beta due to gcc 3.21. The Driver modules gives the 
error: The Module was compiled with a gcc version 2 compiler where your kernel 
was compiled with a version 3 gcc. This is known not to work.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.get the newest NVIDIA_kernel package (rpm or src) from Nvidisas sit
2.unpack or try to install with rpm -ivh
3.try to do "make" to compile and install the module
	

Actual Results:  always fails to install, the compile actually works but when 
doing insmod NVDriever it gives the error.

Expected Results:  the module should load flawlessly

Additional info:

if there could be made some kind of choice to install gcc 2.9X it would be 
good, or even a choice of 2 kernels one compiled with gcc 2.9x and one with 
3.21. I think a lot of people have Nvidia Cards and use their drivers.
Comment 1 Jakub Jelinek 2002-08-26 06:52:49 EDT
gcc296 is in compat-gcc package. Or you can insmod -f if you think it will work.
Best bug NVidia to either release gcc 3.2 compiled .o files, or even better
opensource the drivers.

Note You need to log in before you can comment on or make changes to this bug.