Bug 725722 - cluster.rng from ccs needs to match cluster.rng from cman
cluster.rng from ccs needs to match cluster.rng from cman
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ricci (Show other bugs)
6.1
x86_64 Linux
urgent Severity medium
: rc
: ---
Assigned To: Chris Feist
Cluster QE
: ZStream
: 733471 (view as bug list)
Depends On: 726571
Blocks: 728247 732616 743047
  Show dependency treegraph
 
Reported: 2011-07-26 07:37 EDT by Aleksandr Brezhnev
Modified: 2014-07-04 14:06 EDT (History)
10 users (show)

See Also:
Fixed In Version: ccs-0.16.2-42.el6
Doc Type: Bug Fix
Doc Text:
Prior to this update, the /usr/share/ccs/cluster.rng schema file did not contain definition of the "suborg" option for the fence_cisco_ucs agent. As a consequence, the cluster.conf file was not changed when adding a fencing instance definition with the "suborg" option. With this update, the cluster.rng schema has been modified to match the schema present in the cman package.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:33:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add suborg option to the cluster configuration schema definition for the fence_cisco_ucs agent (544 bytes, patch)
2011-07-26 07:37 EDT, Aleksandr Brezhnev
no flags Details | Diff
Unit test based on problem description; tested with patch. (812 bytes, text/plain)
2011-08-08 13:54 EDT, Lon Hohberger
no flags Details

  None (edit)
Description Aleksandr Brezhnev 2011-07-26 07:37:45 EDT
Created attachment 515257 [details]
Patch to add suborg option to the cluster configuration schema definition for the fence_cisco_ucs agent

Description of problem:

The fencing agent for Cisco UCS included into RHEL 6.1 Cluster supports "suborg" option but it is not defined in the schema for the cluster.conf file.  As a result, utilities like "ccs" complain about schema violation at the attempt to define fencing for UCS blades with suborg parameter and the fenced daemon does not start if this definition is forced into the cluster configuration file.

Version-Release number of selected component (if applicable):
ccs-0.16.2-35.el6.x86_64
fence-agents-3.0.12-23.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL6 with High Availability Add-on

yum -y groupinstall 'High Availability'

2. Create a configuration file for a sample cluster:

ccs -f cluster.conf --createcluster sample
ccs -f cluster.conf --addnode node-1
ccs -f cluster.conf --addnode node-2
ccs -f cluster.conf --addfencedev ucs agent=fence_cisco_ucs ipaddr=192.168.0.1 login=admin passwd=PASSWORD
ccs -f cluster.conf --addmethod UCS node-1
ccs -f cluster.conf --addmethod UCS node-2

3. Add a fencing instance definition with "suborg" option:

ccs -f cluster.conf --addfenceinst ucs node-1 UCS port=Blade-1 suborg=/org-MyOrg/org-MySubOrg/

Actual results:

Error message:
Validation Failure, unable to modify configuration file (use -i to ignore this \
error).

The cluster.conf file is not changed.
  
Expected results:

No messages. The cluster.conf file is updated with the new fencing instance definition.

Additional info:

The schema file /usr/share/ccs/cluster.rng does not contain definition of the suborg option for the fence_cisco_ucs agent.

It should be added with the attached patch.
Comment 2 Aleksandr Brezhnev 2011-08-05 09:48:16 EDT
We need to be sure that the schema is fixed in /usr/share/ccs/cluster.rng and /usr/share/cluster/cluster.rng.  The fix for BZ #728247 in 6.1.z is implemented as a patch to /usr/share/cluster/cluster.rng.   The same should be done for /usr/share/ccs/cluster.rng.
Comment 5 Lon Hohberger 2011-08-08 13:54:47 EDT
Created attachment 517269 [details]
Unit test based on problem description; tested with patch.
Comment 6 Chris Feist 2011-08-10 14:25:54 EDT
Easy way to test is to install the latest cman (currently cman-3.0.12.1-10.el6) and the latest ccs and run the following command: 

diff -q /usr/share/cluster/cluster.rng /usr/share/ccs/cluster.rng

If the files are different, then fail.  If the files are the same, then pass.

You will also want to run the script lon included in Comment #5 to verify things are working properly with the ucs_agent as well.
Comment 7 Chris Feist 2011-08-10 14:59:20 EDT
Before fix:

[root@ask-04 ~]# diff -q /usr/share/cluster/cluster.rng /usr/share/ccs/cluster.rng
Files /usr/share/cluster/cluster.rng and /usr/share/ccs/cluster.rng differ
[root@ask-04 ~]#

After fix:
[root@ask-04 ~]# diff -q /usr/share/cluster/cluster.rng /usr/share/ccs/cluster.rng
[root@ask-04 ~]#

Running lon's script from Comment #5

Before fix:
[root@ask-03 ~]# ./lonscript.sh 
Node node-1 added.
Node node-2 added.
Method UCS added to node-1.
Method UCS added to node-2.
Validation Failure, unable to modify configuration file (use -i to ignore this error).
unable to add suborg
[root@ask-03 ~]# 


After fix:
[root@ask-04 ~]# ./lonscript.sh 
Node node-1 added.
Node node-2 added.
Method UCS added to node-1.
Method UCS added to node-2.
          <device name="ucs" port="Blade-1" suborg="/org-MyOrg/org-MySubOrg/"/>
SUCCESS
[root@ask-04 ~]#
Comment 11 Tomas Capek 2011-08-25 10:01:45 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The fencing agent for Cisco UCS, included in the Red Hat Enterprise Linux 6.1 cluster, supports the "suborg" option. However, this option was not defined in the schema for the /etc/cluster/cluster.conf file. As a consequence, utilities such as ccs returned error messages about the schema violation at the attempt to define fencing for UCS blade servers with the "suborg" option, and the fenced daemon did not start if this definition was forced into the cluster configuration file. With this update, a patch that adds the "suborg" option to the cluster configuration schema definition for the fence_cisco_ucs agent has been provided, thus fixing this bug.
Comment 13 Chris Feist 2011-09-13 13:09:38 EDT
Changing the title of the bug to more accurately represent what needs to be fixed.
Comment 14 Chris Feist 2011-09-13 17:51:21 EDT
*** Bug 733471 has been marked as a duplicate of this bug. ***
Comment 15 Chris Feist 2011-09-13 18:03:36 EDT
Deleted Technical Notes Contents.

Old Contents:
The fencing agent for Cisco UCS, included in the Red Hat Enterprise Linux 6.1 cluster, supports the "suborg" option. However, this option was not defined in the schema for the /etc/cluster/cluster.conf file. As a consequence, utilities such as ccs returned error messages about the schema violation at the attempt to define fencing for UCS blade servers with the "suborg" option, and the fenced daemon did not start if this definition was forced into the cluster configuration file. With this update, a patch that adds the "suborg" option to the cluster configuration schema definition for the fence_cisco_ucs agent has been provided, thus fixing this bug.
Comment 16 Chris Feist 2011-09-15 17:36:23 EDT
Dev Test Results:

Before Fix:

[root@ask-04 ~]# diff /usr/share/cluster/cluster.rng /usr/share/ccs/cluster.rng
10d9
< - uidgid
173,193d171
< <!-- uidgid block -->

<.. snip ..>

<         </optional>
<         <optional>


After fix:
[root@ask-04 ~]# diff /usr/share/cluster/cluster.rng /usr/share/ccs/cluster.rng
[root@ask-04 ~]# 


[root@ask-04 ~]# rpm -q cman fence-agents resource-agents
cman-3.0.12.1-19.el6.x86_64
fence-agents-3.1.5-9.el6.x86_64
resource-agents-3.9.2-6.el6.x86_64
[root@ask-04 ~]# rpm -q ccs
ccs-0.16.2-42.el6.x86_64
Comment 18 Eliska Slobodova 2011-10-07 10:23:01 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Prior to this update, the /usr/share/ccs/cluster.rng schema file did not contain definition of the "suborg" option for the fence_cisco_ucs agent. As a consequence, the cluster.conf file was not changed when adding a fencing instance definition with the "suborg" option. With this update, the cluster.rng schema has been modified to match the schema present in the cman package.
Comment 19 errata-xmlrpc 2011-12-06 12:33:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1698.html

Note You need to log in before you can comment on or make changes to this bug.