Bug 725724 - USB-3G modem time-out problem
Summary: USB-3G modem time-out problem
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 14
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-26 11:44 UTC by Perazim
Modified: 2011-10-30 00:31 UTC (History)
5 users (show)

Fixed In Version: kernel-2.6.35.14-100.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-30 00:31:17 UTC
Type: ---


Attachments (Terms of Use)

Description Perazim 2011-07-26 11:44:38 UTC
Description of problem: 

When some 3G modems are plugged, modemmanager sequentially tries all the USB serial ports detected looking for the port that will be used for the PPP connection. Some 3G modems lave a lot of these ports and because of a 30 second timeout when multiplied by 6 ports it take 5x30=>150 seconds to completely timeout and only after this time will one see the 3G modem appear in the list of NetworkManager. 

This problem was fixed in the 2.6.37 kernel by Dan Williams. It needs to be applied to the 2.6.35 kernel used in Fedora 14. I am supporting quite a few F-14 systems using these 3G modems and because of the refusal by the users to upgrade to F-15 because of the new and much different desktop I need to get this fixed in F-14. 

I have tried myself to patch the 2.6.35 kernel with the patches used for 2.6.37 but without success. Maybe I missed something.

The module affected by Dan Williams patch for 2.6.27 was drivers/usb/serial/usb_wwan.c

Version-Release number of selected component (if applicable): 2.6.35


How reproducible: Always


Steps to Reproduce: Plug Alcatel X220D 3G modem and wait 2.5 minutes before it is recognized.
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Perazim 2011-07-26 11:53:22 UTC
Dan Williams patch for for 2.6.37 not 2.6.27

Comment 2 Dave Jones 2011-10-11 14:32:15 UTC
added the patch for the next build.

Comment 3 Perazim 2011-10-11 15:47:24 UTC
Thanks. I really appreciate this. Any idea what the timing on this next build would be?

Perazim

Comment 4 Dave Jones 2011-10-11 18:01:39 UTC
I'll start one at the end of today, so you could grab it from koji then.
I don't have a timeline on when I'll push it as an update through regular updates yet. Probably not until I've accumulated a few more fixes.

Comment 5 Perazim 2011-10-12 14:34:30 UTC
Just tested kernel-2.6.35.14-98.fc14 from koji and it works for me.

Thanks.

Comment 6 Fedora Update System 2011-10-21 20:47:26 UTC
kernel-2.6.35.14-100.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/kernel-2.6.35.14-100.fc14

Comment 7 Fedora Update System 2011-10-22 08:26:47 UTC
Package kernel-2.6.35.14-100.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-2.6.35.14-100.fc14'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-14747
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2011-10-30 00:31:17 UTC
kernel-2.6.35.14-100.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.