Bug 72578 - PCMCIA not detected
PCMCIA not detected
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Alan Cox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-25 15:53 EDT by Alan Cox
Modified: 2007-03-26 23:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 14:46:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2002-08-25 15:53:44 EDT
On my board with a VIA i82365 PCMCIA controller the installer failed to set up
the PCMCIA interface after firstboot. Interestingly enough it -did- find it in
the installer itself

I assume anaconda should have written this to the /etc/sysconfig/pcmcia ?
Comment 1 Michael Fulbright 2002-08-26 16:44:19 EDT
Bill kudzu has the honors correct?

If it doesn't it needs to.  If someone installs a PCMCIA adapter in a desktop
box we need to  pick it up.
Comment 2 Alan Cox 2002-08-26 18:47:46 EDT
Desktop actually shouldnt be relevant, it appears identicaly to the wired in ISA
non cardbus one on a laptop, same I/O the lot
Comment 3 Bill Nottingham 2002-08-26 23:08:10 EDT
Um, no, anaconda writes /etc/sysconfig/pcmcia.
Comment 4 Jeremy Katz 2002-08-26 23:14:57 EDT
What does kernel-pcmcia-cs's /sbin/probe return?
Comment 5 Alan Cox 2002-08-27 08:35:36 EDT
/sbin/probe
PCI bridge probe: not found.
Intel PCIC probe: not found.
Databook TCIC-2 probe: not found.

The kernel PCMCIA however detects it fine

Comment 6 Bill Nottingham 2002-08-27 21:01:54 EDT
The kernel detects it using what module? yenta_socket?
Comment 7 Alan Cox 2002-08-28 07:28:47 EDT
The kernel i82365 probe check finds it. That probe however may well not be safe
for general poking to see if hardware is present. I guess this is 8.1 stuff or
not a bug in fact. The /sbin/probe does less (and I suspect safer probing)

Reassigned to kernel and to me to investigate further post 8.0

Comment 8 Alan Cox 2003-06-05 14:46:07 EDT
Seems risky and its legacy hardware nowdays. Also with a modern box you have to
set the PCI IRQs up by hand anyway

Note You need to log in before you can comment on or make changes to this bug.