Bug 725802 - vdsmd becomes defunct when blocking traffic between SPM to Master Storage Domain
vdsmd becomes defunct when blocking traffic between SPM to Master Storage Domain
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Dan Kenigsberg
Kiril Nesenko
storage
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-26 11:34 EDT by Rami Vaknin
Modified: 2014-07-10 20:07 EDT (History)
10 users (show)

See Also:
Fixed In Version: vdsm-4.9-92
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 02:32:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm logs (737.13 KB, application/x-gzip)
2011-07-26 11:34 EDT, Rami Vaknin
no flags Details

  None (edit)
Description Rami Vaknin 2011-07-26 11:34:57 EDT
Created attachment 515308 [details]
vdsm logs

Env: rhevm-3.0.0_0001-18.el6.x86_64, vdsm-4.9-84.el6.x86_64

Scenario:
1 host in the data center, 1 iscsi storage domain, blocking traffic to the storage using iptables

Result:
vdsmd stopped and does not start, it becomes defunct for ~30 seconds


[root@stone-vds1 ~]# ps -ww `pgrep vdsm`
  PID TTY      STAT   TIME COMMAND
 8981 ?        S<     0:00 /usr/bin/python /usr/share/vdsm//vdsm
 8983 ?        S<     0:00 /usr/bin/python /usr/share/vdsm//vdsm
24820 ?        Z<l    0:21 [vdsm] <defunct>
[root@stone-vds1 ~]#
Comment 8 Dan Kenigsberg 2011-07-28 08:58:38 EDT
(this is yet untested, but I'm considering to retry starting vdsm even the first try after fencing fails.)

http://gerrit.usersys.redhat.com/755
Comment 11 Kiril Nesenko 2011-08-25 04:15:19 EDT
After a defunct vdsm continues to run.
Verified
ic138.1
vdsm-4.9-95.el6.x86_64
Comment 12 errata-xmlrpc 2011-12-06 02:32:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1782.html

Note You need to log in before you can comment on or make changes to this bug.